summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-10 21:40:06 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-10 21:40:06 +0900
commit67c6b80a7ef21602770cb574b9950550b7d84991 (patch)
treec757b6a357d84fae83e50d8fe9c1f6a970301f11 /app-i18n/libskk
parentapp-i18n/libskk: drop old (diff)
downloadgentoo-67c6b80a7ef21602770cb574b9950550b7d84991.tar.gz
gentoo-67c6b80a7ef21602770cb574b9950550b7d84991.tar.bz2
gentoo-67c6b80a7ef21602770cb574b9950550b7d84991.zip
app-i18n/libskk: new snapshot
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/libskk')
-rw-r--r--app-i18n/libskk/Manifest1
-rw-r--r--app-i18n/libskk/libskk-1.0.5_p20210830.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/libskk/Manifest b/app-i18n/libskk/Manifest
index 1fefdb16cf33..96281f41a24f 100644
--- a/app-i18n/libskk/Manifest
+++ b/app-i18n/libskk/Manifest
@@ -1 +1,2 @@
DIST libskk-1.0.5.tar.xz 564488 BLAKE2B e7108bd2f44e5a0a0756cd25da4b07376b36604d6d2159b283e8a5f4ef76006210ff993d58b653cbce01ae4c9e003acf4acbd93ebc40711fec2600e514c49e9f SHA512 6db675edba89b83da0c29afb42644c39bcb0ccfc47f067a18e0eda817df4f58a86c86e8747080018c132d8734754a6fd8a30fe6578050eb93ff636edeed534ab
+DIST libskk-1.0.5_p20210830.tar.gz 190676 BLAKE2B 6b9f058669929efb292692b5047084e2e95e2003a9ecd093205b198bf201249811f672d74e8ee283e6b1f5a94b6a72c79dddb12c950ffe6958ca6aef3aaea5d9 SHA512 2a34111627a43de2d854e2236fd69ec5577b162b097b6e964b891cf09eafaed0d9c3f657bcb1f78ec985a3e2adbed079d37e5e873d1ec35e5f7c66960135ee2b
diff --git a/app-i18n/libskk/libskk-1.0.5_p20210830.ebuild b/app-i18n/libskk/libskk-1.0.5_p20210830.ebuild
new file mode 100644
index 000000000000..945a61075ae3
--- /dev/null
+++ b/app-i18n/libskk/libskk-1.0.5_p20210830.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools vala vcs-snapshot virtualx
+
+EGIT_COMMIT="5f5e5c2d3facfec9f577fb66032e6f1994ed5d44"
+
+DESCRIPTION="GObject-based library to deal with Japanese kana-to-kanji conversion method"
+HOMEPAGE="https://github.com/ueno/libskk"
+SRC_URI="https://github.com/ueno/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ x11-libs/libxkbcommon
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="$(vala_depend)
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ vala_src_prepare
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ export GSETTINGS_BACKEND="memory"
+ virtx emake check
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete || die
+}