summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-09-26 15:41:50 -0400
committerMike Pagano <mpagano@gentoo.org>2024-09-26 15:41:50 -0400
commitb487c0695871417acfdd9799827075db84d8b6dd (patch)
tree5e74dee746dc43b285c866a927100a147b0b5964 /app-forensics
parentdev-cpp/cpp-httplib: Stabilize 0.16.3 ppc64, #940286 (diff)
downloadgentoo-b487c0695871417acfdd9799827075db84d8b6dd.tar.gz
gentoo-b487c0695871417acfdd9799827075db84d8b6dd.tar.bz2
gentoo-b487c0695871417acfdd9799827075db84d8b6dd.zip
app-forensics/lynis: add 3.1.2
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/lynis/Manifest1
-rw-r--r--app-forensics/lynis/lynis-3.1.2.ebuild69
-rw-r--r--app-forensics/lynis/metadata.xml5
3 files changed, 75 insertions, 0 deletions
diff --git a/app-forensics/lynis/Manifest b/app-forensics/lynis/Manifest
index a205a47150f4..9d8334923534 100644
--- a/app-forensics/lynis/Manifest
+++ b/app-forensics/lynis/Manifest
@@ -1 +1,2 @@
DIST lynis-3.1.1.tar.gz 344324 BLAKE2B 056e689f00ac0fa74bd1a6dc3915cbd70f28cdb5461e0749b68ce2cf84e425c295425f7bb6d5aeb0208693a0e38290cb90925e392928257c79bc5887f6e58498 SHA512 c37366154e03a661a7e995d14c651d5503c7189f50edfd194d8b7034e001b9610bfe79917221156ab3607f7c348625ea956fb0acb46a6c7e64a7d189dbcfd4ee
+DIST lynis-3.1.2.tar.gz 355241 BLAKE2B fb224f626d1e42eaaae108a986e4b93fba36b1e6a8ea23208568e3be3dac782f60a9a996ebcc512eaea0234a95e16464a931895b28e3bf8c718ccc8c40126c68 SHA512 e471549898407da3eee58fc404be1e8a166d41e1a527c8d4942882bff60e91554c3a759e08bced7a7c177ccc7a9d7a0b7cad340f3edc3b0e2a39a17302b018ae
diff --git a/app-forensics/lynis/lynis-3.1.2.ebuild b/app-forensics/lynis/lynis-3.1.2.ebuild
new file mode 100644
index 000000000000..f294c7a6665f
--- /dev/null
+++ b/app-forensics/lynis/lynis-3.1.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit bash-completion-r1 systemd
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="https://cisofy.com/lynis/"
+SRC_URI="https://github.com/CISOfy/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cron systemd"
+
+RDEPEND="
+ app-shells/bash
+ cron? ( !systemd? ( virtual/cron ) )"
+
+src_install() {
+ doman lynis.8
+ dodoc FAQ README
+ newdoc CHANGELOG.md CHANGELOG
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+ sed -i -e 's/\/path\/to\///' "${S}/extras/systemd/${PN}.service" || die "Sed Failed!"
+ systemd_dounit "${S}/extras/systemd/${PN}.service" || die "Sed Failed!"
+ systemd_dounit "${S}/extras/systemd/${PN}.timer"
+
+ if ! use cron; then
+ ebegin "removing cron files from installation image"
+ rm -rfv "${ED}/etc/cron.daily" || die
+ eend "$?"
+ fi
+}
+
+pkg_postinst() {
+ if use cron; then
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ echo
+ ewarn "Both 'cron' and 'systemd' flags are enabled."
+ ewarn "So both ${PN}.target and cron files were installed."
+ ewarn "Please don't use 2 implementations at the same time."
+ ewarn "Cronjobs are usually enabled by default via /etc/cron.* jobs"
+ ewarn "If you want to use systemd ${PN}.target timers"
+ ewarn "disable 'cron' flag and reinstall ${PN}"
+ echo
+ else
+ einfo "A cron script has been installed to ${ROOT}/etc/cron.daily/lynis."
+ fi
+ fi
+}
diff --git a/app-forensics/lynis/metadata.xml b/app-forensics/lynis/metadata.xml
index 72bf02bbb435..d93aeae57bbc 100644
--- a/app-forensics/lynis/metadata.xml
+++ b/app-forensics/lynis/metadata.xml
@@ -8,4 +8,9 @@
<use>
<flag name="cron">Install /etc/cron.* files</flag>
</use>
+ <upstream>
+ <bugs-to>https://github.com/CISOfy/lynis/issues</bugs-to>
+ <changelog>https://raw.githubusercontent.com/CISOfy/lynis/refs/heads/master/CHANGELOG.md</changelog>
+ <remote-id type="github">CISOfy/lynis</remote-id>
+ </upstream>
</pkgmetadata>