summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-11-07 06:41:21 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-11-07 06:41:33 -0500
commit4922a49a7ac5e31090f1a84ae51703d26c4c9ded (patch)
tree2ac271d7868216b1697f2e80e9843160595dff94 /app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild
parentmedia-sound/mpd: make meson dependency stricter (diff)
downloadgentoo-4922a49a7ac5e31090f1a84ae51703d26c4c9ded.tar.gz
gentoo-4922a49a7ac5e31090f1a84ae51703d26c4c9ded.tar.bz2
gentoo-4922a49a7ac5e31090f1a84ae51703d26c4c9ded.zip
app-eselect/eselect-postgresql: Bump to 2.4
In some conditions, ln will follow symlinks it isn’t supposed to. Add the -n switch to keep that from happening. Bug: https://bugs.gentoo.org/662810 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Aaron Swenson <titanofold@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild')
-rw-r--r--app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild b/app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild
new file mode 100644
index 000000000000..d5d878eac874
--- /dev/null
+++ b/app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to select the default PostgreSQL slot"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~titanofold/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RDEPEND="app-admin/eselect"
+
+# All dev-db/postgresql ebuilds from 10.0 on are well supported. Earlier
+# ebuilds may present some quality of life issues.
+PDEPEND="
+ !<dev-db/postgresql-9.6.2-r1:9.6
+ !<dev-db/postgresql-9.5.6-r1:9.5
+ !<dev-db/postgresql-9.4.11-r1:9.4
+ !<dev-db/postgresql-9.3.16-r1:9.3
+ !<dev-db/postgresql-9.2.20-r1
+"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins postgresql.eselect
+
+ dosym eselect /usr/bin/postgresql-config
+}
+
+pkg_postinst() {
+ postgresql-config update
+}