summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-17 02:47:46 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-17 04:42:12 -0400
commitb5b7cf63acf06503ec6b13bb9fa5148b4f85d365 (patch)
treeb1575e14ff0cef34baba14cee69014d8105e440a /app-emulation
parentapp-emulation/vkd3d: drop 1.0, 1.1, 1.1-r1 (diff)
downloadgentoo-b5b7cf63acf06503ec6b13bb9fa5148b4f85d365.tar.gz
gentoo-b5b7cf63acf06503ec6b13bb9fa5148b4f85d365.tar.bz2
gentoo-b5b7cf63acf06503ec6b13bb9fa5148b4f85d365.zip
app-emulation/vkd3d: drop broken live ebuild
There is little use for this package anymore given recent Wine versions bundle it to ease handling mingw-built PE files and do not use the system's ELF libraries. In-tree wine-7.0 can still optionally use it so it's not going anywhere yet, but fixing and keeping the live ebuild for stable releases doesn't seem useful. Note that if interested in the latest features from Valve, these are included in vkd3d-proton-9999 instead and can be used by any Wine versions (similarly to dxvk by adding dlls to the Wine prefix). Bug: https://bugs.gentoo.org/685918 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vkd3d/vkd3d-9999.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/app-emulation/vkd3d/vkd3d-9999.ebuild b/app-emulation/vkd3d/vkd3d-9999.ebuild
deleted file mode 100644
index e64cc1a24558..000000000000
--- a/app-emulation/vkd3d/vkd3d-9999.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib-minimal
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
- inherit git-r3
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
-fi
-
-#Tests fail: https://bugs.gentoo.org/838655
-RESTRICT="test"
-
-IUSE="spirv-tools"
-RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
- media-libs/vulkan-loader[${MULTILIB_USEDEP},X]
- x11-libs/xcb-util:=[${MULTILIB_USEDEP}]
- x11-libs/xcb-util-keysyms:=[${MULTILIB_USEDEP}]
- x11-libs/xcb-util-wm:=[${MULTILIB_USEDEP}]"
-
-DEPEND="${RDEPEND}
- dev-util/spirv-headers
- dev-util/vulkan-headers"
-
-DESCRIPTION="D3D12 to Vulkan translation library"
-HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-multilib_src_configure() {
- local myconf=(
- $(use_with spirv-tools)
- --disable-doxygen-pdf
- )
-
- ECONF_SOURCE=${S} econf "${myconf[@]}"
-}