summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-16 19:44:05 +0000
committerSam James <sam@gentoo.org>2020-09-16 19:44:05 +0000
commit0ed9aab19dd619b2e985e5f20675e1e54b985219 (patch)
tree3b44cf680a65a46ecd718a6632f2deaf3aeab4d7 /app-emulation
parentapp-text/ghostscript-gpl: bump to v9.53.1 (diff)
downloadgentoo-0ed9aab19dd619b2e985e5f20675e1e54b985219.tar.gz
gentoo-0ed9aab19dd619b2e985e5f20675e1e54b985219.tar.bz2
gentoo-0ed9aab19dd619b2e985e5f20675e1e54b985219.zip
app-emulation/spectemu: bump to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch4
-rw-r--r--app-emulation/spectemu/files/spectemu-0.99.3-build.patch4
-rw-r--r--app-emulation/spectemu/spectemu-0.99.3-r1.ebuild26
3 files changed, 21 insertions, 13 deletions
diff --git a/app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch b/app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch
index 6e813d6373e5..0fd6ebc7e6f6 100644
--- a/app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch
+++ b/app-emulation/spectemu/files/spectemu-0.99.3-automagic.patch
@@ -1,5 +1,5 @@
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
@@ -121,13 +121,22 @@
dnl -----------------------------------------------------------
dnl Check for SVGALIB
diff --git a/app-emulation/spectemu/files/spectemu-0.99.3-build.patch b/app-emulation/spectemu/files/spectemu-0.99.3-build.patch
index 1c354a5fa933..9c5ac95c594b 100644
--- a/app-emulation/spectemu/files/spectemu-0.99.3-build.patch
+++ b/app-emulation/spectemu/files/spectemu-0.99.3-build.patch
@@ -1,5 +1,5 @@
---- Makefile.in
-+++ Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
@@ -44,17 +44,19 @@
./mkinstalldirs $(i_bindir) $(i_mandir)
diff --git a/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild b/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild
index 14d083630681..907f557d003d 100644
--- a/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild
+++ b/app-emulation/spectemu/spectemu-0.99.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="48k ZX Spectrum Emulator"
HOMEPAGE="http://kempelen.iit.bme.hu/~mszeredi/spectemu/spectemu.html"
@@ -16,17 +16,25 @@ IUSE="readline svga +X"
REQUIRED_USE="|| ( svga X )"
-DEPEND="X? ( x11-base/xorg-proto
+DEPEND="
+ X? (
+ x11-base/xorg-proto
>=x11-libs/libX11-1.0.0
>=x11-libs/libXext-1.0.0
- >=x11-libs/libXxf86vm-1.0.0 )
- readline? ( sys-libs/readline )"
+ >=x11-libs/libXxf86vm-1.0.0
+ )
+ readline? ( sys-libs/readline:= )
+"
RDEPEND="${DEPEND}
svga? ( media-libs/svgalib )"
+PATCHES=(
+ "${FILESDIR}"/${P}-automagic.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-automagic.patch
- epatch "${FILESDIR}"/${P}-build.patch
+ default
eautoreconf
}
@@ -38,5 +46,5 @@ src_configure() {
}
src_install() {
- emake install_root="${D}" install
+ emake install_root="${ED}" install
}