summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-03-21 18:00:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-03-21 18:01:37 +0100
commita96898f4d499099f3a6b90c60fe6b43d80b30508 (patch)
treeed75a41ba7ade7ff3c14f304eb388aa54c99bb08 /app-emulation/pcem
parentapp-pda/libplist: Version bump to 2.1.0, EAPI 7 (diff)
downloadgentoo-a96898f4d499099f3a6b90c60fe6b43d80b30508.tar.gz
gentoo-a96898f4d499099f3a6b90c60fe6b43d80b30508.tar.bz2
gentoo-a96898f4d499099f3a6b90c60fe6b43d80b30508.zip
app-emulation/pcem: fix compilation with gcc >= 10.x
Since the source fix is not trivial, adding -fcommon for now. Closes: https://bugs.gentoo.org/713772 Package-Manager: Portage-2.3.94, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-emulation/pcem')
-rw-r--r--app-emulation/pcem/pcem-15-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-emulation/pcem/pcem-15-r1.ebuild b/app-emulation/pcem/pcem-15-r1.ebuild
index db947638e010..fad135956903 100644
--- a/app-emulation/pcem/pcem-15-r1.ebuild
+++ b/app-emulation/pcem/pcem-15-r1.ebuild
@@ -41,6 +41,10 @@ src_prepare() {
}
src_configure() {
+ # Does not compile with -fno-common.
+ # See https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=3443
+ append-cflags -fcommon
+
local myeconfargs=(
--enable-release-build
$(use_enable alsa)
@@ -66,6 +70,6 @@ pkg_postinst() {
elog "In order to use PCem, you will need some roms for various emulated systems."
elog "You can either install globally for all users or locally for yourself."
elog ""
- elog "To install globally, put your ROM file into '${ROOT}/usr/share/pcem/roms/<system>'."
- elog "To install locally, put your ROM file into '~/.pcem/roms/<system>'."
+ elog "To install globally, put your ROM files into '${ROOT}/usr/share/pcem/roms/<system>'."
+ elog "To install locally, put your ROM files into '~/.pcem/roms/<system>'."
}