summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-31 00:54:58 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-31 02:02:54 +0200
commit29a681099af149fdd6d6130435360192de6e71af (patch)
tree5d81ce4e0c46a68fbd14f393e89ccbe294e43102 /app-emacs
parentapp-emacs/consult: drop old 1.6 (diff)
downloadgentoo-29a681099af149fdd6d6130435360192de6e71af.tar.gz
gentoo-29a681099af149fdd6d6130435360192de6e71af.tar.bz2
gentoo-29a681099af149fdd6d6130435360192de6e71af.zip
app-emacs/consult: bump to 1.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/consult/Manifest1
-rw-r--r--app-emacs/consult/consult-1.8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/consult/Manifest b/app-emacs/consult/Manifest
index 76466a382a84..e790a34c25ac 100644
--- a/app-emacs/consult/Manifest
+++ b/app-emacs/consult/Manifest
@@ -1 +1,2 @@
DIST consult-1.7.tar.gz 104660 BLAKE2B 4ff23ad57a4a7454b4749ed2c4dc97b91f21f2d7b41b1f5549cb6d5e4920ebbb82b77ce4c5b4cf07663cda74e3d9b9d637fad8bc93c453706e0c595e106a5870 SHA512 1822d0e3aa9db4a93c491c1a1ae2db7e96016d1c1275a41d258c4bf9b2220c770966b6c286e39f3306c03427f12678be6321136c1024590fab63ae5a67289da0
+DIST consult-1.8.tar.gz 104909 BLAKE2B b946274cc83e0b3372895c30e2d3b303bc9c5f7c4da7a8f4fc9521ac96f60e3c07e17df6bee7f9ec3594ff3d3fcdbdc21ea1cd6ccb74c8cc0d13bfd42b0ddd9d SHA512 3497be58ab11338453864a77b35e23f60f4c9ba901f4a335428671d629bc8d92f3dddb47ded9876a7964603935714851ebbc4bedcded254fb6cb0ef80b415601
diff --git a/app-emacs/consult/consult-1.8.ebuild b/app-emacs/consult/consult-1.8.ebuild
new file mode 100644
index 000000000000..7f3ed9bf0123
--- /dev/null
+++ b/app-emacs/consult/consult-1.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read for GNU Emacs"
+HOMEPAGE="https://github.com/minad/consult/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-28.1
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}