summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-07-10 08:58:34 +0100
committerMatthew Smith <matthew@gentoo.org>2022-07-10 09:39:03 +0100
commit28410d857142012bce38a78abf686737872eb25c (patch)
tree5215ca0166c6d638eaa63724f1616c31ab4df552 /app-emacs
parentmedia-gfx/renderdoc: drop 1.18-r2, 1.19 (diff)
downloadgentoo-28410d857142012bce38a78abf686737872eb25c.tar.gz
gentoo-28410d857142012bce38a78abf686737872eb25c.tar.bz2
gentoo-28410d857142012bce38a78abf686737872eb25c.zip
app-emacs/corfu: add 0.26
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/corfu/Manifest1
-rw-r--r--app-emacs/corfu/corfu-0.26.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/corfu/Manifest b/app-emacs/corfu/Manifest
index 0ce16439238a..165a6da827fb 100644
--- a/app-emacs/corfu/Manifest
+++ b/app-emacs/corfu/Manifest
@@ -1 +1,2 @@
DIST corfu-0.25.tar.gz 38366 BLAKE2B 297c8c556d32ee9f0a42265bbcd9b7cdd19881b8d85a9c92b6be84cb52e5558996cb16da596d13349fd1c9c72c7b6247e003ab48fcc41fd4acbe2d151b8e2e90 SHA512 602a9072cfa6a75672e1879e8da95b59355cc720482c8946311446c5722d13d0db6171eab8d899b689a689fe306d11f9b063e6bdc07dc710d9ee8f6f15b5aeee
+DIST corfu-0.26.tar.gz 38840 BLAKE2B 47dfcd2430cfd37c912cc2101760692bb1e4ef788bafec64760c81b02412119156b99d57a129e31d7109a62a073dfeb836453076f8bc59ece835015b4ec19ac0 SHA512 3996528e5ee9992462bc2cb241c36b7a05aeca460de0a04db542e6cd9eb7352067283ea4d8c668053003a7afc2dacc97e3b634842b847c05450fd8472ae8249a
diff --git a/app-emacs/corfu/corfu-0.26.ebuild b/app-emacs/corfu/corfu-0.26.ebuild
new file mode 100644
index 000000000000..7cc6d4bc7c42
--- /dev/null
+++ b/app-emacs/corfu/corfu-0.26.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}