summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-07 16:48:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-07 17:04:32 +0200
commit32d18e4a6bde5c00ce0f6b89533e7882ded1642e (patch)
tree31885727b22815769fd3cf79ae9b75e5a5b8b94a /app-emacs/which-key
parentnet-wireless/lorcon: use newer pep517 (diff)
downloadgentoo-32d18e4a6bde5c00ce0f6b89533e7882ded1642e.tar.gz
gentoo-32d18e4a6bde5c00ce0f6b89533e7882ded1642e.tar.bz2
gentoo-32d18e4a6bde5c00ce0f6b89533e7882ded1642e.zip
app-emacs/which-key: new package; add version 3.6.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/which-key')
-rw-r--r--app-emacs/which-key/Manifest1
-rw-r--r--app-emacs/which-key/files/50which-key-gentoo.el3
-rw-r--r--app-emacs/which-key/metadata.xml13
-rw-r--r--app-emacs/which-key/which-key-3.6.0.ebuild36
4 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/which-key/Manifest b/app-emacs/which-key/Manifest
new file mode 100644
index 000000000000..e90b9a0855e8
--- /dev/null
+++ b/app-emacs/which-key/Manifest
@@ -0,0 +1 @@
+DIST which-key-3.6.0.tar.gz 462441 BLAKE2B e56dacff2003192e769e53f728538246f4b3c2f00273022a81382e3afaf4c1b7016a2da468ade1e1f0b3b33df7352a327f75c43fef990c432bbb55f3aad7a934 SHA512 8ecfa3e5d0529cc0e879772d2ea2fcbbdfc8ab559dc8befddd63b91e6ed726baa6c0069bc0f30dc417eb288d02a281f1b07b5c966a361f390cab4d7392c2e56c
diff --git a/app-emacs/which-key/files/50which-key-gentoo.el b/app-emacs/which-key/files/50which-key-gentoo.el
new file mode 100644
index 000000000000..d46c0735a841
--- /dev/null
+++ b/app-emacs/which-key/files/50which-key-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'which-key-mode "which-key"
+ "Toggle which-key-mode." t)
diff --git a/app-emacs/which-key/metadata.xml b/app-emacs/which-key/metadata.xml
new file mode 100644
index 000000000000..d1d749f4165a
--- /dev/null
+++ b/app-emacs/which-key/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/justbur/emacs-which-key/issues/</bugs-to>
+ <remote-id type="github">justbur/emacs-which-key</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/which-key/which-key-3.6.0.ebuild b/app-emacs/which-key/which-key-3.6.0.ebuild
new file mode 100644
index 000000000000..e5243f24d20c
--- /dev/null
+++ b/app-emacs/which-key/which-key-3.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Display the key bindings following your currently entered keys"
+HOMEPAGE="https://github.com/justbur/emacs-which-key/"
+SRC_URI="https://github.com/justbur/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.org img )
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="To enable \"which-key-mode\" globally,
+ add the following to your init file:
+ \n\t(which-key-mode)"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} -l ${PN}.el -l ${PN}-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ einstalldocs
+ readme.gentoo_create_doc
+}