summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/folding
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/folding')
-rw-r--r--app-emacs/folding/Manifest2
-rw-r--r--app-emacs/folding/files/50folding-gentoo.el4
-rw-r--r--app-emacs/folding/folding-2012.0226.1623.ebuild18
-rw-r--r--app-emacs/folding/folding-2013.0613.1821.ebuild18
-rw-r--r--app-emacs/folding/metadata.xml5
5 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/folding/Manifest b/app-emacs/folding/Manifest
new file mode 100644
index 000000000000..fd3ca6154ea9
--- /dev/null
+++ b/app-emacs/folding/Manifest
@@ -0,0 +1,2 @@
+DIST folding-2012.0226.1623.el.bz2 49503 SHA256 d1d00dd48284c7509c24003d56e8cf86c46839880d6775efe76682e1cd859482 SHA512 efb645e46e55174f2b538b6812f36d08f576f765ffffdf25af756c852e7bfd6455cb3bc3a540089a60600251b2c144384b7f58b412840a95ce614efd9d5b50c9 WHIRLPOOL 42a17c72d91cee51bec9d37466ef1e9b9812ac05cf01b6dc006e0ec204bff2edc84a2a776e656deb86ca17917eaf7d1716c849d67cdcf9f6c5a1017c99cf9588
+DIST folding-2013.0613.1821.el.xz 52164 SHA256 bc818ec6a07537d716b28ea1b1a3798c042503b967578e387894599ea1ab5bf3 SHA512 9eb7cf4e1b01d7f37969bab0a66ad564da3742981ec0623b3100b0aef1bb997a80c91b88286ac673775edd197110496e1849210cc40fe310d8a478471cc1ec53 WHIRLPOOL b67c9e477738c0cc0ed88cae486eff12e773d9ed0e32a9c54981861e6e492ece2d98d100947d39c6add87b8121044d4f55ede0ab3f5e36df6e824cbd46ed582d
diff --git a/app-emacs/folding/files/50folding-gentoo.el b/app-emacs/folding/files/50folding-gentoo.el
new file mode 100644
index 000000000000..7a741f4c2f2d
--- /dev/null
+++ b/app-emacs/folding/files/50folding-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'folding-mode "folding" "Folding mode" t)
+(autoload 'turn-off-folding-mode "folding" "Folding mode" t)
+(autoload 'turn-on-folding-mode "folding" "Folding mode" t)
diff --git a/app-emacs/folding/folding-2012.0226.1623.ebuild b/app-emacs/folding/folding-2012.0226.1623.ebuild
new file mode 100644
index 000000000000..d94e682b5276
--- /dev/null
+++ b/app-emacs/folding/folding-2012.0226.1623.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A folding-editor-like Emacs minor mode"
+HOMEPAGE="http://www.emacswiki.org/emacs/FoldingMode"
+# taken from http://git.savannah.gnu.org/cgit/emacs-tiny-tools.git
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/folding/folding-2013.0613.1821.ebuild b/app-emacs/folding/folding-2013.0613.1821.ebuild
new file mode 100644
index 000000000000..e1001ea03da6
--- /dev/null
+++ b/app-emacs/folding/folding-2013.0613.1821.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A folding-editor-like Emacs minor mode"
+HOMEPAGE="http://www.emacswiki.org/emacs/FoldingMode"
+# taken from http://git.savannah.gnu.org/cgit/emacs-tiny-tools.git
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/folding/metadata.xml b/app-emacs/folding/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/folding/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>