summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-04-05 01:00:22 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-04-05 01:08:31 +0200
commit707659e3a7320c5e46d0383f74d626d2fe2dee38 (patch)
tree98d7a3531132da7e580c4a6fa263c77fc4ead2d5 /app-editors/ng
parentnet-misc/mosh: version bump to 1.3.0. (diff)
downloadgentoo-707659e3a7320c5e46d0383f74d626d2fe2dee38.tar.gz
gentoo-707659e3a7320c5e46d0383f74d626d2fe2dee38.tar.bz2
gentoo-707659e3a7320c5e46d0383f74d626d2fe2dee38.zip
app-editors/ng: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-editors/ng')
-rw-r--r--app-editors/ng/files/ng-1.5beta1-ncurses.patch6
-rw-r--r--app-editors/ng/ng-1.5_beta1-r2.ebuild70
2 files changed, 73 insertions, 3 deletions
diff --git a/app-editors/ng/files/ng-1.5beta1-ncurses.patch b/app-editors/ng/files/ng-1.5beta1-ncurses.patch
index 5395ba94ea78..6808d911152b 100644
--- a/app-editors/ng/files/ng-1.5beta1-ncurses.patch
+++ b/app-editors/ng/files/ng-1.5beta1-ncurses.patch
@@ -1,6 +1,6 @@
---- configure.orig 2004-05-12 09:26:44.000000000 +0900
-+++ configure 2004-05-12 09:27:06.000000000 +0900
-@@ -1077,3 +1077,3 @@
+--- a/configure 2004-05-12 09:26:44.000000000 +0900
++++ b/configure 2004-05-12 09:27:06.000000000 +0900
+@@ -1077,3+1077,3 @@
rm -f conftest*
-test "$ac_cv_search_tgetstr" = "no" && for i in curses ncurses termlib; do
+test "$ac_cv_search_tgetstr" = "no" && for i in ncurses termlib; do
diff --git a/app-editors/ng/ng-1.5_beta1-r2.ebuild b/app-editors/ng/ng-1.5_beta1-r2.ebuild
new file mode 100644
index 000000000000..637538b3379b
--- /dev/null
+++ b/app-editors/ng/ng-1.5_beta1-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${P/_beta/beta}"
+
+DESCRIPTION="Emacs like micro editor Ng -- based on mg2a"
+HOMEPAGE="http://tt.sakura.ne.jp/~amura/ng/"
+SRC_URI="http://tt.sakura.ne.jp/~amura/archives/ng/${MY_P}.tar.gz"
+
+LICENSE="Emacs"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="canna"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ !dev-java/nailgun
+ canna? ( app-i18n/canna )"
+
+DEPEND="
+ ${RDEPEND}
+ sys-apps/sed"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${MY_P}-ncurses.patch"
+ "${FILESDIR}/${MY_P}-configure.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i -e "/NO_BACKUP/s/undef/define/" config.h || die "sed failed"
+ pushd sys/unix > /dev/null || die
+ eautoconf
+ popd > /dev/null || die
+ cp sys/unix/configure . || die
+}
+
+src_configure() {
+ econf $(use_enable canna)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ng
+ dodoc docs/* MANIFEST dot.ng
+
+ insinto /usr/share/ng
+ doins bin/*
+
+ insinto /etc/skel
+ newins dot.ng .ng
+}
+
+pkg_postinst() {
+ elog
+ elog "If you want to use user Config"
+ elog "cp /etc/skel/.ng ~/.ng"
+ elog "and edit your .ng configuration file."
+ elog
+}