summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-30 08:49:51 +0000
committerSam James <sam@gentoo.org>2023-07-30 12:42:54 +0100
commit0ba1fe984709fecbc6d538692e488bdfd383e3c5 (patch)
tree448a2729285e914dfb265806b786fdf1e8df24f0 /app-dicts
parentdev-python/graph-tool: drop 2.56 (diff)
downloadgentoo-0ba1fe984709fecbc6d538692e488bdfd383e3c5.tar.gz
gentoo-0ba1fe984709fecbc6d538692e488bdfd383e3c5.tar.bz2
gentoo-0ba1fe984709fecbc6d538692e488bdfd383e3c5.zip
app-dicts/eblook: Fix call to undeclared library function strcmp
Closes: https://bugs.gentoo.org/894360 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32100 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild34
-rw-r--r--app-dicts/eblook/files/eblook-1.6.1-clang-16-buildfix.patch11
2 files changed, 45 insertions, 0 deletions
diff --git a/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild b/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild
new file mode 100644
index 000000000000..ce4c207a67e0
--- /dev/null
+++ b/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Interactive search utility for electronic dictionaries"
+HOMEPAGE="http://openlab.ring.gr.jp/edict/eblook/"
+SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${PN}-$(ver_cut 1-3).tar.gz"
+SRC_URI+=" mirror://debian/pool/main/e/eblook/eblook_$(ver_cut 1-3)-$(ver_cut 5).debian.tar.xz"
+S="${WORKDIR}"/${PN}-$(ver_cut 1-3)
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+DEPEND=">=dev-libs/eb-3.3.4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+ "${FILESDIR}"/${PN}-1.6.1-clang-16-buildfix.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-eb-conf="${EPREFIX}"/etc/eb.conf
+}
diff --git a/app-dicts/eblook/files/eblook-1.6.1-clang-16-buildfix.patch b/app-dicts/eblook/files/eblook-1.6.1-clang-16-buildfix.patch
new file mode 100644
index 000000000000..cae0edcdb186
--- /dev/null
+++ b/app-dicts/eblook/files/eblook-1.6.1-clang-16-buildfix.patch
@@ -0,0 +1,11 @@
+Bug: https://bugs.gentoo.org/894360
+--- a/getopt.c
++++ b/getopt.c
+@@ -40,6 +40,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C