summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-07 15:41:50 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:47:46 +0200
commit06d50e9610aba8a47bfe920d22892e1e19d66c8c (patch)
treee40097fbdc44647e4a1b8a786c9e2341c7db9461 /app-dicts/ydpdict
parentapp-dicts/verbiste: add 0.1.48 (diff)
downloadgentoo-06d50e9610aba8a47bfe920d22892e1e19d66c8c.tar.gz
gentoo-06d50e9610aba8a47bfe920d22892e1e19d66c8c.tar.bz2
gentoo-06d50e9610aba8a47bfe920d22892e1e19d66c8c.zip
app-dicts/ydpdict: add 1.0.5
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37072 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-dicts/ydpdict')
-rw-r--r--app-dicts/ydpdict/Manifest1
-rw-r--r--app-dicts/ydpdict/ydpdict-1.0.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-dicts/ydpdict/Manifest b/app-dicts/ydpdict/Manifest
index d66c4d77547d..97310111c500 100644
--- a/app-dicts/ydpdict/Manifest
+++ b/app-dicts/ydpdict/Manifest
@@ -1 +1,2 @@
DIST ydpdict-1.0.3.tar.gz 185721 BLAKE2B 1db80dc20dd6d71c4b7fed2051bbfae1021fd1ea15ca1f993e8e095912fbcc8d599d8f480143d185fd11c6a1414d7f29ae67a9f5cffda624b434d198cddc5c68 SHA512 ca50c485f10aa4c4691a27a474a5ae814be3bb183b4927728f14de67af1e11a281e5272fc5777d6573e69dd00d3da2223b78d729132764338c92489f20eb17e8
+DIST ydpdict-1.0.5.tar.gz 191401 BLAKE2B 5b57e16d36fe744e435924546c55bb5d0e130a1e76ec743cb871ccf71bb53d5999a8ba5eb3cca0db8ae6d4f3680642d2d243f067a4bef653d375ccf9e203f460 SHA512 12fcee0612560ebea3942ce31ef6b4927bd033cd45e9dd6e677a8aefcf3a81feb267ad77953e3ed1a904428586e41df8dd8c732cdbe1e9a3220cc46c153030c1
diff --git a/app-dicts/ydpdict/ydpdict-1.0.5.ebuild b/app-dicts/ydpdict/ydpdict-1.0.5.ebuild
new file mode 100644
index 000000000000..c29a3178c033
--- /dev/null
+++ b/app-dicts/ydpdict/ydpdict-1.0.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Interface for the Collins Dictionary"
+HOMEPAGE="https://github.com/wojtekka/ydpdict"
+SRC_URI="https://github.com/wojtekka/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="ao"
+
+RDEPEND="
+ app-dicts/libydpdict
+ sys-libs/ncurses:=[unicode(+)]
+ ao? ( media-libs/libao )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ao libao)
+}
+
+src_install() {
+ dodir "/etc"
+ default
+}
+
+pkg_postinst() {
+ echo
+ elog "Note that to use this program you'll need the original Collins Dictionary"
+ elog "datafiles (dict100.*, dict101.*). These can be found in the Dabasase/"
+ elog "directory of the Windows version of the Collins dictionary. Once you obtain"
+ elog "the files, put them into /usr/share/ydpdict"
+ elog
+ elog "Some configuration options can be set in /etc/ydpdict.conf"
+ echo
+}