summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-02 23:22:09 +0100
committerSam James <sam@gentoo.org>2022-10-03 01:38:08 +0100
commitd9d172170b72c133c81edc803bd14c517730d078 (patch)
treee39693b3bd07cbf1b145ae7651a0029699314f00 /app-dicts/eblook
parentgames-mud/tf: fix implicit function decls. (Clang 16+) (diff)
downloadgentoo-d9d172170b72c133c81edc803bd14c517730d078.tar.gz
gentoo-d9d172170b72c133c81edc803bd14c517730d078.tar.bz2
gentoo-d9d172170b72c133c81edc803bd14c517730d078.zip
app-dicts/eblook: add 1.6.1_p16 (Debian fork, fixes build w/ Clang 16+)
Includes a bunch of other warning fixes too. Closes: https://bugs.gentoo.org/870829 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-dicts/eblook')
-rw-r--r--app-dicts/eblook/Manifest1
-rw-r--r--app-dicts/eblook/eblook-1.6.1_p16.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-dicts/eblook/Manifest b/app-dicts/eblook/Manifest
index a2cc29521e69..fea1fa67e52f 100644
--- a/app-dicts/eblook/Manifest
+++ b/app-dicts/eblook/Manifest
@@ -1 +1,2 @@
DIST eblook-1.6.1.tar.gz 440727 BLAKE2B 313dcc89fea9dbc8dac8c9fda618cf4e39d0cfef4f67ba7cf2ab29e3b1c8dc0559407c1f1c68c9994594b784acb445c6fe988456e14da324bd38c89de23f3ffe SHA512 36f4f383a53a0332a2dec0e40d2743c93d35c9f51a7de2d2706bbc18a4fde215d4e345feb175bebf428c1760cb32e73148fb9b336fcde8c0d8b924ee6ecfd6a4
+DIST eblook_1.6.1-16.debian.tar.xz 92044 BLAKE2B 9a6b19541c910694b0b079cfb4bcb9ae38f4505e25a08f4c17dd7af6cf04a1b5e9a33aadbda7a4c5a8509699b0a5efe4eb5962b6cdd6f63a82105bacad5231a7 SHA512 538956ac54cedae76563bcbc6c8ac7f97be4cdc2d9cc506fc14444dc3a7c9631040a1becf259c1f465b4e875333ffb43d6af5c8102b9fc8b862b7567cafc8d83
diff --git a/app-dicts/eblook/eblook-1.6.1_p16.ebuild b/app-dicts/eblook/eblook-1.6.1_p16.ebuild
new file mode 100644
index 000000000000..802d730eb3d5
--- /dev/null
+++ b/app-dicts/eblook/eblook-1.6.1_p16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Interactive search utility for electronic dictionaries"
+HOMEPAGE="http://openlab.ring.gr.jp/edict/eblook/"
+SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${PN}-$(ver_cut 1-3).tar.gz"
+SRC_URI+=" mirror://debian/pool/main/e/eblook/eblook_$(ver_cut 1-3)-$(ver_cut 5).debian.tar.xz"
+S="${WORKDIR}"/${PN}-$(ver_cut 1-3)
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+DEPEND=">=dev-libs/eb-3.3.4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-eb-conf="${EPREFIX}"/etc/eb.conf
+}