summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-06-19 11:34:32 +0200
committerPacho Ramos <pacho@gentoo.org>2024-06-19 11:42:09 +0200
commita632ccef4a06219bebd8dc0000b1e75b4601a83a (patch)
tree2b2d478e9c85198abaec02d68030f475591e4076 /app-crypt
parentdev-libs/nwjs: drop 0.82.0 (diff)
downloadgentoo-a632ccef4a06219bebd8dc0000b1e75b4601a83a.tar.gz
gentoo-a632ccef4a06219bebd8dc0000b1e75b4601a83a.tar.bz2
gentoo-a632ccef4a06219bebd8dc0000b1e75b4601a83a.zip
app-crypt/pius: Support python 3.12 and port to PEP517
Closes: https://bugs.gentoo.org/909869 Closes: https://bugs.gentoo.org/922153 Closes: https://bugs.gentoo.org/929292 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pius/pius-3.0.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/pius/pius-3.0.0-r2.ebuild b/app-crypt/pius/pius-3.0.0-r2.ebuild
new file mode 100644
index 000000000000..184aaf851b53
--- /dev/null
+++ b/app-crypt/pius/pius-3.0.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for signing and email all UIDs on a set of PGP keys"
+HOMEPAGE="https://www.phildev.net/pius/ https://github.com/jaymzh/pius"
+SRC_URI="https://github.com/jaymzh/pius/releases/download/v${PV}/pius-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=app-crypt/gnupg-2.0.0"
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}/${P}-Fix-typos-132.patch"
+ "${FILESDIR}/${P}-pius-keyring-mgr-Fix-constants-134.patch"
+ "${FILESDIR}/${P}-Fix-typo-in-readme-135.patch"
+ "${FILESDIR}/${P}-Minor-fixes-for-pius-report-137.patch"
+)
+
+python_test() {
+ ${EPYTHON} -m unittest discover -s test/* -v || die
+}