summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-12 21:05:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-12 21:26:15 +0200
commit2965c15400d008dc4445f7b9de3ae99cc5c12c41 (patch)
treead5bdec0ca80ba2c09bdab6273da15b6cb6a172c /app-crypt
parentapp-crypt/acme: Enable py3.13 (diff)
downloadgentoo-2965c15400d008dc4445f7b9de3ae99cc5c12c41.tar.gz
gentoo-2965c15400d008dc4445f7b9de3ae99cc5c12c41.tar.bz2
gentoo-2965c15400d008dc4445f7b9de3ae99cc5c12c41.zip
app-crypt/certbot: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/certbot-2.10.0.ebuild13
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild13
2 files changed, 16 insertions, 10 deletions
diff --git a/app-crypt/certbot/certbot-2.10.0.ebuild b/app-crypt/certbot/certbot-2.10.0.ebuild
index 021ba0724501..9d6b94a1db1f 100644
--- a/app-crypt/certbot/certbot-2.10.0.ebuild
+++ b/app-crypt/certbot/certbot-2.10.0.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -36,9 +36,6 @@ IUSE="selinux"
BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"
@@ -57,5 +54,11 @@ RDEPEND="
selinux? ( sec-policy/selinux-certbot )
"
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 3f039135a22d..09fbd7e66ef7 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -36,9 +36,6 @@ IUSE="selinux"
BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"
@@ -57,5 +54,11 @@ RDEPEND="
selinux? ( sec-policy/selinux-certbot )
"
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}