summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/xor-analyze
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/xor-analyze')
-rw-r--r--app-crypt/xor-analyze/Manifest1
-rw-r--r--app-crypt/xor-analyze/metadata.xml5
-rw-r--r--app-crypt/xor-analyze/xor-analyze-0.5.ebuild25
3 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/xor-analyze/Manifest b/app-crypt/xor-analyze/Manifest
new file mode 100644
index 000000000000..d62ae5261916
--- /dev/null
+++ b/app-crypt/xor-analyze/Manifest
@@ -0,0 +1 @@
+DIST xor-analyze-0.5.tar.gz 26635 SHA256 5f66b0f11fd284335780781aa0b18abef4d03fae7808d5e99053ee5f05d41ce9 SHA512 e28aef799dc6f64a57609638f578bbe66c3ced5784599a65be6bf4ee14921600b7d292880f1288b5ad81ed3dd0897b6aeff2d741b96efc30cf0eab453e4b21b1 WHIRLPOOL b81bf3f384fc085a9ee5b0b4ab552efc9fff2d47a2f0b9e6fb2b1842a6e30202a7d7ec104c1beac680c0be6caedb4b770231b2ec6cd9f0b204361f0fc92b7b35
diff --git a/app-crypt/xor-analyze/metadata.xml b/app-crypt/xor-analyze/metadata.xml
new file mode 100644
index 000000000000..effbbf33eac8
--- /dev/null
+++ b/app-crypt/xor-analyze/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-crypt/xor-analyze/xor-analyze-0.5.ebuild b/app-crypt/xor-analyze/xor-analyze-0.5.ebuild
new file mode 100644
index 000000000000..6d09b34370db
--- /dev/null
+++ b/app-crypt/xor-analyze/xor-analyze-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="program for cryptanalyzing xor 'encryption' with variable key length"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=xor-analyze"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_compile() {
+ rm -f Makefile
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" xor-analyze xor-enc || die
+}
+
+src_install() {
+ dobin xor-analyze xor-enc || die
+ dosym xor-enc /usr/bin/xor-dec
+ dodoc README TODO
+}