summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-12 16:57:01 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-12 17:59:23 -0400
commit30c690b650d3d1afca08be0bdd9e923c23f94469 (patch)
tree8266d51d744ff5842fbe635f6a19ac26038d324c /app-crypt/seahorse
parentgui-libs/libhandy: Version bump to 1.2.0 (diff)
downloadgentoo-30c690b650d3d1afca08be0bdd9e923c23f94469.tar.gz
gentoo-30c690b650d3d1afca08be0bdd9e923c23f94469.tar.bz2
gentoo-30c690b650d3d1afca08be0bdd9e923c23f94469.zip
app-crypt/seahorse: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/Manifest1
-rw-r--r--app-crypt/seahorse/seahorse-40.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index e10f4b2a20b1..7e9ae5f973b1 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1,2 +1,3 @@
DIST seahorse-3.36.2.tar.xz 1695824 BLAKE2B e4efb20f952e879b0ff17a9c8664ba61d10c69e377a2fdda52904a8bf5c026d147f9feb9b55c07982f256b366f756dd1567a522d89969c8c5c461f653a130676 SHA512 6a0cb7847fe9917d6d6da31f9b81a4737e425d451fc80604d8e3deb9fa57798f04aa577dae68bc156a15743975f74fbde5ff06a0b05b34228bdc9ef2539b6451
DIST seahorse-3.38.1.tar.xz 1725480 BLAKE2B 348d9fe1208a9205c58c5655ce97b79c279e2e3506f041a1ebac1f7c83666186ec792bafe7f23b470dd1202a12bc974376b8c369888c6fa194739e7a15973d63 SHA512 1a064ecaf1a25aa84010f914043c3776eba464844598b15e0822217ad330396516df64afed1aeffb3c7b6102d1477c280ec8ec32101cf9f5120c433431b9df32
+DIST seahorse-40.0.tar.xz 1309064 BLAKE2B dd179ef13c79454b30571959b33c02a523591fa9d59957e0c30ec5d75a52bd8e9a5b420214f85d5feac0849d69a51ddcee808ab47e4bf97d7ac99094f853bc9a SHA512 c389420fb1b3d54c1b9a1004f2c8b9e50118a1ffcba02aa8cfdd2223d1bc117368c9a1ad875c59abd319d95eb93ec3de2e9cedadbfc1d6a0997d613c8256c60b
diff --git a/app-crypt/seahorse/seahorse-40.0.ebuild b/app-crypt/seahorse/seahorse-40.0.ebuild
new file mode 100644
index 000000000000..790a848544a2
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-40.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Manage your passwords and encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.58:2
+ >=app-crypt/gcr-3.38:=
+ >=app-crypt/gpgme-1.14.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=app-crypt/gnupg-2.2
+ >=gui-libs/libhandy-1.1:1=
+ >=app-crypt/libsecret-0.16
+ dev-libs/libpwquality
+ net-misc/openssh
+ ldap? ( net-nds/openldap:= )
+ >=net-libs/libsoup-2.33.92:2.4
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxml2:2
+ app-crypt/gcr[vala]
+ app-crypt/libsecret[vala]
+ gui-libs/libhandy:1[vala]
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Dpgp-support=true
+ -Dcheck-compatible-gpg=false # keep lowest version listed as compatible as min dep for gnupg RDEPEND
+ -Dpkcs11-support=true
+ -Dkeyservers-support=true
+ -Dhkp-support=true
+ $(meson_use ldap ldap-support)
+ $(meson_use zeroconf key-sharing)
+ -Dmanpage=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}