summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-09-19 21:12:16 +0200
committerKristian Fiskerstrand <k_f@gentoo.org>2017-09-20 14:39:41 +0200
commit23020e14b68c739d73a377ae952017d3304a3fd4 (patch)
treec4f99cfb96644e51b1e8bd1df92f7696aa56adee /app-crypt/pinentry
parentapp-crypt/pinentry: Drop USE=qt4 (diff)
downloadgentoo-23020e14b68c739d73a377ae952017d3304a3fd4.tar.gz
gentoo-23020e14b68c739d73a377ae952017d3304a3fd4.tar.bz2
gentoo-23020e14b68c739d73a377ae952017d3304a3fd4.zip
app-crypt/pinentry: Sort IUSE and DEPENDs
Gentoo-bug: 598288 Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/pinentry-1.0.0.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/app-crypt/pinentry/pinentry-1.0.0.ebuild b/app-crypt/pinentry/pinentry-1.0.0.ebuild
index bd8af4aec998..366151430811 100644
--- a/app-crypt/pinentry/pinentry-1.0.0.ebuild
+++ b/app-crypt/pinentry/pinentry-1.0.0.ebuild
@@ -12,31 +12,28 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="emacs gtk ncurses qt5 caps gnome-keyring static"
+IUSE="caps emacs gnome-keyring gtk ncurses qt5 static"
CDEPEND="
- >=dev-libs/libgpg-error-1.17
+ app-eselect/eselect-pinentry
>=dev-libs/libassuan-2.1
>=dev-libs/libgcrypt-1.6.3
- ncurses? ( sys-libs/ncurses:0= )
+ >=dev-libs/libgpg-error-1.17
+ caps? ( sys-libs/libcap )
+ gnome-keyring? ( app-crypt/libsecret )
gtk? ( x11-libs/gtk+:2 )
+ ncurses? ( sys-libs/ncurses:0= )
qt5? (
dev-qt/qtgui:5
dev-qt/qtwidgets:5
- )
- caps? ( sys-libs/libcap )
+ )
static? ( >=sys-libs/ncurses-5.7-r5:0=[static-libs,-gpm] )
- app-eselect/eselect-pinentry
- gnome-keyring? ( app-crypt/libsecret )
"
-
DEPEND="${CDEPEND}
sys-devel/gettext
virtual/pkgconfig
"
-
-RDEPEND="
- ${CDEPEND}
+RDEPEND="${CDEPEND}
gnome-keyring? ( app-crypt/gcr )
"
@@ -67,13 +64,13 @@ src_configure() {
econf \
--enable-pinentry-tty \
+ $(use_with caps libcap) \
$(use_enable emacs pinentry-emacs) \
+ $(use_enable gnome-keyring libsecret) \
+ $(use_enable gnome-keyring pinentry-gnome3) \
$(use_enable gtk pinentry-gtk2) \
$(use_enable ncurses pinentry-curses) \
$(use_enable ncurses fallback-curses) \
- $(use_with caps libcap) \
- $(use_enable gnome-keyring libsecret) \
- $(use_enable gnome-keyring pinentry-gnome3) \
$(use_enable qt5 pinentry-qt) \
MOC="$(qt5_get_bindir)"/moc
}