summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-07-16 18:10:10 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-07-16 18:10:10 -0500
commite8b8b6b8297a1b0d16c454e5a379e66e17ebb1b8 (patch)
tree2968a0f38680ce251374a3ef941de98bb26cf15b /app-containers
parentdev-cpp/eigen: destabilize 3.4.0-r3 for ~arm64, ~sparc (diff)
downloadgentoo-e8b8b6b8297a1b0d16c454e5a379e66e17ebb1b8.tar.gz
gentoo-e8b8b6b8297a1b0d16c454e5a379e66e17ebb1b8.tar.bz2
gentoo-e8b8b6b8297a1b0d16c454e5a379e66e17ebb1b8.zip
app-containers/cosign: add 2.2.4
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/cosign/Manifest2
-rw-r--r--app-containers/cosign/cosign-2.2.4.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/cosign/Manifest b/app-containers/cosign/Manifest
index 501d631a7ce8..df934f1cd5af 100644
--- a/app-containers/cosign/Manifest
+++ b/app-containers/cosign/Manifest
@@ -8,3 +8,5 @@ DIST cosign-2.2.1-deps.tar.xz 487130076 BLAKE2B a0adbfc4d6230f4ba1013dfc28638752
DIST cosign-2.2.1.tar.gz 853562 BLAKE2B 40894d00d6071206221010337cb517ee9559518764a0d991df3363cb4dc381a0af4cd31e60c0c1fc6cffce6086af08c908ccf503893356f224f95b1d4085b195 SHA512 84f2308bbb1968eaf6d0d95e2dcb8efa2c42cd2599298b37d576e5e87f0cf6c1153c330b034908c0c7557953e0a7d964eaa4a8768f7dc35900f5f427d8fe7713
DIST cosign-2.2.3-deps.tar.xz 429760040 BLAKE2B 47ee9a4f6305a670e1818ce74a9da351fc763d4196334d738ab48b9dcba06f4be43ce2ba77dc879aae59ada2fa2ea66168a223c9da1029e02e140590dd1733a5 SHA512 481f8593b80d91996f2b2d4de10acad8bf1c5db3cf099a9683fd7da307c1142c870166a9222e58f9449a060248c94fecf35343dccc07d5cbf2acbdc00c0aef29
DIST cosign-2.2.3.tar.gz 845096 BLAKE2B 2017cc1716899640cbfc10ce093280a1ee4789eb1e8a8077978ebe4efe38075efa73ccb1abecb41eaa64dc16e652dbb709be7f195a6542284d86b2d9fb5128f3 SHA512 fc488c80dab3d05e0eca714c6107fada01dfddc2b68747676665d20a3f229224bbe36bfc60625c581c2e80dd10ad1421e142cf7ef6e24eba0894a708f2d10f06
+DIST cosign-2.2.4-deps.tar.xz 153098164 BLAKE2B 6e900386c307fc5bc19057ab62d87eb6ff597916d3cabf14372ce8cd4b39c0fd11ec787fcb96d3db297c7907584617307ab3a87b2e797de56ef6dee4cff3f50b SHA512 d0873fd15819c9c580a8f70a01859ac8e166ba79f9702fe757d95b482ee92914c66b13b9abe3093f79b9657612d9c7da8ce662aca7bc680ff533c7fcb1848e30
+DIST cosign-2.2.4.tar.gz 840586 BLAKE2B 22522fc70ff6b01957af2e294b7fdad740d55cc9710f9023246855dd9383be0688934f27e5b32cde3383cdfe3c02cd2de5547a515a14c1442ac85afc9e566b8f SHA512 3a2e2e7ea3964428bc7c4adb9475fbb730cbe2b7dfa7a5eb5cf350d88a4f3a9aef64f00574c7f38bf0074cb3e386cd26e6cfe4558ce5989ea557b654aa82ef71
diff --git a/app-containers/cosign/cosign-2.2.4.ebuild b/app-containers/cosign/cosign-2.2.4.ebuild
new file mode 100644
index 000000000000..97ef9d95434b
--- /dev/null
+++ b/app-containers/cosign/cosign-2.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_HASH=fb651b4ddd8176bd81756fca2d988dd8611f514d
+SOURCE_DATE_EPOCH=1712786247
+
+DESCRIPTION="container signing utility"
+HOMEPAGE="https://sigstore.dev"
+SRC_URI="https://github.com/sigstore/cosign/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="test"
+
+src_compile() {
+ emake \
+ GIT_HASH=${GIT_HASH} \
+ GIT_VERSION=v${PV} \
+ GIT_TREESTATE=clean \
+ SOURCE_DATE_EPOCH=${SOURCE_DATE_EPOCH}
+}
+
+src_install() {
+ dobin cosign
+ einstalldocs
+dodoc CHANGELOG.md
+}