summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-07-27 12:10:33 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-07-27 12:10:33 -0500
commit8d5d5df0f4b6314eef1d25b9a1617ba24df8386b (patch)
tree65f0381d543b1f4f29ca8128f41514bacddb58b8 /app-containers
parentapp-containers/grype: drop 0.42.0 (diff)
downloadgentoo-8d5d5df0f4b6314eef1d25b9a1617ba24df8386b.tar.gz
gentoo-8d5d5df0f4b6314eef1d25b9a1617ba24df8386b.tar.bz2
gentoo-8d5d5df0f4b6314eef1d25b9a1617ba24df8386b.zip
app-containers/syft: add 0.52.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/syft/Manifest2
-rw-r--r--app-containers/syft/syft-0.52.0.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index e496a66a12b4..ea89f160dacc 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -2,3 +2,5 @@ DIST syft-0.47.0-deps.tar.xz 631564724 BLAKE2B 4eb6dedb2173d5dda214b4bb450fa6e85
DIST syft-0.47.0.tar.gz 3846983 BLAKE2B 2833b360de24fc8c5ca2073bc776e2d33f8c78d7d25f8a622e8420b528e4c517c1298c1479d916a2a90b97cb44f1b5e407a9dc2a09016e7ccf6238d0050eb696 SHA512 997d6e7139be8c686ee38df9fe42fa50dac17e522c51db005628cf3fd6a97ef9f9758e86fe6c6e58a199d852bc4eeac88b3932c5f3847547382987cd02260551
DIST syft-0.51.0-deps.tar.xz 632084588 BLAKE2B f9b3e4e41521c25b6e338f2b8f3bba0be08e7608d95de7dba6f5f104e22b8de8a4b419e574e19634099a3bbc55556f83949c68abd5ae52d14b5e97cb9306bf22 SHA512 819236c275762cc42c60339ee2d6886f0998f34609ab0bbef3150b23fbcf3cecaea63d92f6e2e161bf3ec30edae00ef467755900fd1c98389db2f9cd8113fbf4
DIST syft-0.51.0.tar.gz 3727474 BLAKE2B ae9f54f421faa530aabbbadd985071f603ccaa32c6cd5f0dd400ea9163a218e8ddd5e7035042a7eda6cd06910ce96ae0f42b7422c932992fad812431a42ac059 SHA512 fb844a76d3f3f303e781cea40ac6fb573927f6465a39da10fe9cffeb08ce7b1e8b8ed4acb219206e53159f802eaa12dce73ce5bc3b868f6f4270a30498b6b767
+DIST syft-0.52.0-deps.tar.xz 962322444 BLAKE2B 696dd14adf54c8ab51cc91d22028ce0ace3b6a5835fb8c3ce6d26080f0ce75d2a9ca332f2275a71706a2152519b01a71577827ac63c12ffb87ad1605ffd18b28 SHA512 b6897a12b8a15c8c2b4672e93ca03fe26a182ee87e48ac4bdd26057f544a6a45aa5ce6317a38e157b99a70830d4a0241f8b4cb15f8fffccaf195ac4c4ff64cd8
+DIST syft-0.52.0.tar.gz 3726656 BLAKE2B de8492adde3bef944a9b853990ba5909aa14ccc223f42833fa2a49d1bd5772455bd3ab9ac3a8886b353dc79c6e93338e43e9c448623bd31c422155e0adb1f276 SHA512 2ffaaa154546061d1d61bf8f0b3d5cf10282dbbb08876cc9e87777a23efdba1fd462c395ee4cf14d334f49ae4575e2db5fe8b5fbe7439dd24ff22ec8efeb6501
diff --git a/app-containers/syft/syft-0.52.0.ebuild b/app-containers/syft/syft-0.52.0.ebuild
new file mode 100644
index 000000000000..2c42d972b97c
--- /dev/null
+++ b/app-containers/syft/syft-0.52.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o bin/syft ./cmd/syft
+}
+
+src_install() {
+dobin bin/*
+}