summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-04 10:53:32 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-04 10:53:32 -0500
commit76f692abaa3b2c822d3075c934f0fc65d2eb6d5e (patch)
treecbb8f4c1abb16dd8de487f0558bba4a869aa3620 /app-containers
parentapp-containers/grype: add 0.45.0 (diff)
downloadgentoo-76f692abaa3b2c822d3075c934f0fc65d2eb6d5e.tar.gz
gentoo-76f692abaa3b2c822d3075c934f0fc65d2eb6d5e.tar.bz2
gentoo-76f692abaa3b2c822d3075c934f0fc65d2eb6d5e.zip
app-containers/syft: add 0.53.4
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/syft/Manifest2
-rw-r--r--app-containers/syft/syft-0.53.4.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index 2610778a3784..cbd6688e7aa2 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -1,2 +1,4 @@
DIST syft-0.52.0-deps.tar.xz 962322444 BLAKE2B 696dd14adf54c8ab51cc91d22028ce0ace3b6a5835fb8c3ce6d26080f0ce75d2a9ca332f2275a71706a2152519b01a71577827ac63c12ffb87ad1605ffd18b28 SHA512 b6897a12b8a15c8c2b4672e93ca03fe26a182ee87e48ac4bdd26057f544a6a45aa5ce6317a38e157b99a70830d4a0241f8b4cb15f8fffccaf195ac4c4ff64cd8
DIST syft-0.52.0.tar.gz 3726656 BLAKE2B de8492adde3bef944a9b853990ba5909aa14ccc223f42833fa2a49d1bd5772455bd3ab9ac3a8886b353dc79c6e93338e43e9c448623bd31c422155e0adb1f276 SHA512 2ffaaa154546061d1d61bf8f0b3d5cf10282dbbb08876cc9e87777a23efdba1fd462c395ee4cf14d334f49ae4575e2db5fe8b5fbe7439dd24ff22ec8efeb6501
+DIST syft-0.53.4-deps.tar.xz 668995648 BLAKE2B a2120e677e1438ea8dc369939c157dcdff772bd98b1f32d6ac3edfb553cfc0f6dfde8dfe86f0b4306a4286dca08646e79f72c3cde8bcc86f7308dff6f22755fe SHA512 beaf914bcecf75d461e241aa3b96ac162dd8e5c1ffd69fa117ea6170b2f6f1c76a424e33e5a29cf177c0c5ac55b3399bae6cab564f055b80ba745dd28ebdef40
+DIST syft-0.53.4.tar.gz 3765398 BLAKE2B 15abe368451c14dc0afa9c0d63cdd10d056c0b09f906478188c772241750e0d9e903bd0efe55d87c0c04c4a5a21fa5bc3e1e63b0115e2b24e068d0a52e68b560 SHA512 9267e45165b860540a89ad6c317351abe26d3089294ec9698fa26b37c4413581424f43aae3f01a111b68806c6de30e8464fce27eda1b1cba442e1e0f613843c5
diff --git a/app-containers/syft/syft-0.53.4.ebuild b/app-containers/syft/syft-0.53.4.ebuild
new file mode 100644
index 000000000000..00e3a35973be
--- /dev/null
+++ b/app-containers/syft/syft-0.53.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=69bde44c6e50a5838cdd2c2c821edb0111013178
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# tests require a running docker daemon
+RESTRICT="test"
+
+src_compile() {
+ local BUILD_DATE
+ BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
+ ego build -o bin/syft -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/syft/internal/version.version=${PV}
+ -X github.com/anchore/syft/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/syft/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/syft/internal/version.gitDescription=v${PV}
+ " ./cmd/syft
+}
+
+src_install() {
+ dobin bin/*
+}