summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Tortuyaux <mtortuyaux@microsoft.com>2024-09-24 17:40:43 +0200
committerJames Le Cuirot <chewi@gentoo.org>2024-09-24 22:58:10 +0100
commit18075bfb7b377c06a05d82d6f6fcbb832dff00eb (patch)
treeebca22366f1f5bbca1a2c5795dd13b3b009a99bb /app-containers
parentapp-containers/runc: add release 1.1.14 (diff)
downloadgentoo-18075bfb7b377c06a05d82d6f6fcbb832dff00eb.tar.gz
gentoo-18075bfb7b377c06a05d82d6f6fcbb832dff00eb.tar.bz2
gentoo-18075bfb7b377c06a05d82d6f6fcbb832dff00eb.zip
app-containers/containerd: bump to 1.7.22
This mainly pulls new runc version (1.1.14) Signed-off-by: Mathieu Tortuyaux <mtortuyaux@microsoft.com> Closes: https://github.com/gentoo/gentoo/pull/38630 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/containerd/Manifest1
-rw-r--r--app-containers/containerd/containerd-1.7.22.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-containers/containerd/Manifest b/app-containers/containerd/Manifest
index c14f1695c07c..c975c19ec600 100644
--- a/app-containers/containerd/Manifest
+++ b/app-containers/containerd/Manifest
@@ -1,3 +1,4 @@
DIST containerd-1.7.15.tar.gz 10071827 BLAKE2B 91de9b7d777d53ecdab4af5bbb0d4ccbe755e4cf0fb7bc99a7bb15c66e0e11ad30aa2af685e0e8b0df80dbeef451704fa056a04b460d92adceebd290977febfc SHA512 84a94c7658a431cfd7a5321ac262d966f4291337ddff14211951b0d2025cd3af25a48175794d2b3a630ffc25ba03047579163546a4758a2fb5d1898cd233854f
DIST containerd-1.7.19.tar.gz 10157428 BLAKE2B 3f51d63d4280a11ffe308c3e65df2fefdd91f543169501cf361bb8c6d5085b6b606cc3425508246ce872c86a475e2d195dd2473fee89a47548cfdfbd810307c2 SHA512 cb58bf5148381f9f0eba096e159592f294f887c5b17f8aaf6de8fed80c515abf4f08c849bbbd266dd85ede09fe709bf7d15a61a749f1136456329c47508dbe34
DIST containerd-1.7.21.tar.gz 10188737 BLAKE2B 0a3eef5bd97b4249963d6e6b80652e2abef0ac7ece726d15efc3b1d364b3525ac7602afecfde3d376bdbec7d5ca39636e09dd8d2a96c420012ef4232afc2a6dd SHA512 fba998c8d7f2907b3e5fb09c3947c3272661ec33379c611c5110ca0151812adcd70ff6b837e97a5d4228d685902276eeb98cd82bb4c46149686e169e81943c75
+DIST containerd-1.7.22.tar.gz 10189969 BLAKE2B b1fac9764a8bac0b883849786bd20c9a8e64d764186c6362978faec5ba360636caccc6c1a7c51c6781aa51f96a4e713968d1e86b54b6fe2fa9e3dfcc07727e64 SHA512 9572f2b0f49365cc3888999a0c0b7d29694922f0cbefb33e1fbbfc71781cde402537da3a23e36fd3a600a1d819bcef9acbeee423df2699fa9e3f07cfde7f9128
diff --git a/app-containers/containerd/containerd-1.7.22.ebuild b/app-containers/containerd/containerd-1.7.22.ebuild
new file mode 100644
index 000000000000..0bd94e9e77cd
--- /dev/null
+++ b/app-containers/containerd/containerd-1.7.22.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+GIT_REVISION=b2ce781edcbd6cb758f172ecab61c79d607cc41d
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.io/"
+SRC_URI="https://github.com/containerd/containerd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
+
+COMMON_DEPEND="
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )
+"
+
+DEPEND="
+${COMMON_DEPEND}
+"
+
+# recommended version of runc is found in script/setup/runc-version
+RDEPEND="
+ ${COMMON_DEPEND}
+ ~app-containers/runc-1.1.14[apparmor?,seccomp?]
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ virtual/pkgconfig
+"
+
+# tests require root or docker
+RESTRICT+="test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/-s -w//" \
+ -e "s/-mod=readonly//" \
+ Makefile || die
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ containerd.service || die
+}
+
+src_compile() {
+ local options=(
+ $(usev apparmor)
+ $(usex btrfs "" "no_btrfs")
+ $(usex cri "" "no_cri")
+ $(usex device-mapper "" "no_devmapper")
+ $(usev seccomp)
+ $(usev selinux)
+ )
+
+ myemakeargs=(
+ BUILDTAGS="${options[*]}"
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')"
+ REVISION="${GIT_REVISION}"
+ VERSION=v${PV}
+ )
+
+ # race condition in man target https://bugs.gentoo.org/765100
+ # we need to explicitly specify GOFLAGS for "go run" to use vendor source
+ emake "${myemakeargs[@]}" man -j1 #nowarn
+ emake "${myemakeargs[@]}" all
+
+}
+
+src_install() {
+ rm "${D}"/bin/gen-manpages
+ dobin bin/*
+ doman man/*
+ newconfd "${FILESDIR}"/${PN}.confd "${PN}"
+ newinitd "${FILESDIR}"/${PN}.initd "${PN}"
+ systemd_dounit containerd.service
+ keepdir /var/lib/containerd
+
+ # we already installed manpages, remove markdown source
+ # before installing docs directory
+ rm -r docs/man || die
+
+ local DOCS=( ADOPTERS.md README.md RELEASES.md ROADMAP.md SCOPE.md docs/. )
+ einstalldocs
+}