summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzesimir Nowak <knowak@microsoft.com>2024-05-24 13:50:50 +0200
committerZac Medico <zmedico@gentoo.org>2024-05-26 16:31:11 -0700
commit1728e374db8721b71bad2ad4ac1e76e949849a5f (patch)
tree1b6bb548acd2153f90d332993aac9388aaa7e54b /app-containers/podman
parentapp-misc/jpipe: enable py3.13 (diff)
downloadgentoo-1728e374db8721b71bad2ad4ac1e76e949849a5f.tar.gz
gentoo-1728e374db8721b71bad2ad4ac1e76e949849a5f.tar.bz2
gentoo-1728e374db8721b71bad2ad4ac1e76e949849a5f.zip
app-containers/podman: Fix cross-compilation issues with gpgme
Need to tell cgo to use proper pkg-config with the PKG_CONFIG environment variable. Bug: https://bugs.gentoo.org/930982 Signed-off-by: Krzesimir Nowak <knowak@microsoft.com> Closes: https://github.com/gentoo/gentoo/pull/36805 Closes: https://bugs.gentoo.org/930982 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/podman')
-rw-r--r--app-containers/podman/podman-4.9.4.ebuild8
-rw-r--r--app-containers/podman/podman-5.0.2.ebuild8
-rw-r--r--app-containers/podman/podman-5.0.3.ebuild8
-rw-r--r--app-containers/podman/podman-9999.ebuild8
4 files changed, 28 insertions, 4 deletions
diff --git a/app-containers/podman/podman-4.9.4.ebuild b/app-containers/podman/podman-4.9.4.ebuild
index 845dcbc2a7aa..ea2bd34e2507 100644
--- a/app-containers/podman/podman-4.9.4.ebuild
+++ b/app-containers/podman/podman-4.9.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{11,12} )
-inherit go-module python-any-r1 tmpfiles linux-info
+inherit go-module python-any-r1 tmpfiles toolchain-funcs linux-info
DESCRIPTION="A tool for managing OCI containers and pods with Docker-compatible CLI"
HOMEPAGE="https://github.com/containers/podman/ https://podman.io/"
@@ -103,6 +103,12 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT="" EPOCH_TEST_COMMIT=""
+ # Use proper pkg-config to get gpgme cflags and ldflags when
+ # cross-compiling, bug 930982.
+ if tc-is-cross-compiler; then
+ tc-export PKG_CONFIG
+ fi
+
# BUILD_SECCOMP is used in the patch to toggle seccomp
emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" BUILD_SECCOMP="$(usex seccomp)" all $(usev wrapper docker-docs)
}
diff --git a/app-containers/podman/podman-5.0.2.ebuild b/app-containers/podman/podman-5.0.2.ebuild
index b535f608f817..738613b007dc 100644
--- a/app-containers/podman/podman-5.0.2.ebuild
+++ b/app-containers/podman/podman-5.0.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{11,12} )
-inherit go-module python-any-r1 tmpfiles linux-info
+inherit go-module python-any-r1 tmpfiles toolchain-funcs linux-info
DESCRIPTION="A tool for managing OCI containers and pods with Docker-compatible CLI"
HOMEPAGE="https://github.com/containers/podman/ https://podman.io/"
@@ -95,6 +95,12 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT="" EPOCH_TEST_COMMIT=""
+ # Use proper pkg-config to get gpgme cflags and ldflags when
+ # cross-compiling, bug 930982.
+ if tc-is-cross-compiler; then
+ tc-export PKG_CONFIG
+ fi
+
# BUILD_SECCOMP is used in the patch to toggle seccomp
emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" BUILD_SECCOMP="$(usex seccomp)" \
all $(usev wrapper docker-docs)
diff --git a/app-containers/podman/podman-5.0.3.ebuild b/app-containers/podman/podman-5.0.3.ebuild
index b535f608f817..738613b007dc 100644
--- a/app-containers/podman/podman-5.0.3.ebuild
+++ b/app-containers/podman/podman-5.0.3.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{11,12} )
-inherit go-module python-any-r1 tmpfiles linux-info
+inherit go-module python-any-r1 tmpfiles toolchain-funcs linux-info
DESCRIPTION="A tool for managing OCI containers and pods with Docker-compatible CLI"
HOMEPAGE="https://github.com/containers/podman/ https://podman.io/"
@@ -95,6 +95,12 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT="" EPOCH_TEST_COMMIT=""
+ # Use proper pkg-config to get gpgme cflags and ldflags when
+ # cross-compiling, bug 930982.
+ if tc-is-cross-compiler; then
+ tc-export PKG_CONFIG
+ fi
+
# BUILD_SECCOMP is used in the patch to toggle seccomp
emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" BUILD_SECCOMP="$(usex seccomp)" \
all $(usev wrapper docker-docs)
diff --git a/app-containers/podman/podman-9999.ebuild b/app-containers/podman/podman-9999.ebuild
index b535f608f817..738613b007dc 100644
--- a/app-containers/podman/podman-9999.ebuild
+++ b/app-containers/podman/podman-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{11,12} )
-inherit go-module python-any-r1 tmpfiles linux-info
+inherit go-module python-any-r1 tmpfiles toolchain-funcs linux-info
DESCRIPTION="A tool for managing OCI containers and pods with Docker-compatible CLI"
HOMEPAGE="https://github.com/containers/podman/ https://podman.io/"
@@ -95,6 +95,12 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT="" EPOCH_TEST_COMMIT=""
+ # Use proper pkg-config to get gpgme cflags and ldflags when
+ # cross-compiling, bug 930982.
+ if tc-is-cross-compiler; then
+ tc-export PKG_CONFIG
+ fi
+
# BUILD_SECCOMP is used in the patch to toggle seccomp
emake BUILDFLAGS="-v -work -x" GOMD2MAN="go-md2man" BUILD_SECCOMP="$(usex seccomp)" \
all $(usev wrapper docker-docs)