summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-09-17 23:21:43 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-09-17 23:40:51 +0200
commit251d1062dd347520c0bcbf72a9722779b406f106 (patch)
tree3b596eb938c55b0c88895feb24ca7cb94418eda3 /app-benchmarks
parentapp-misc/graphlcd-base: unify *magick usage (diff)
downloadgentoo-251d1062dd347520c0bcbf72a9722779b406f106.tar.gz
gentoo-251d1062dd347520c0bcbf72a9722779b406f106.tar.bz2
gentoo-251d1062dd347520c0bcbf72a9722779b406f106.zip
app-benchmarks/cpuburn: fix dynamic relocations
Closes: https://bugs.gentoo.org/913410 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r5.ebuild (renamed from app-benchmarks/cpuburn/cpuburn-1.4a-r4.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r4.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r5.ebuild
index 7c532a610978..37e9bf82a74d 100644
--- a/app-benchmarks/cpuburn/cpuburn-1.4a-r4.ebuild
+++ b/app-benchmarks/cpuburn/cpuburn-1.4a-r5.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MY_PV="${PV/./_}"
+inherit flag-o-matic
+
DESCRIPTION="CPU testing utilities in optimized assembler for maximum loading"
HOMEPAGE="https://web.archive.org/web/20110623074500/pages.sbcglobal.net/redelm/"
SRC_URI="https://dev.gentoo.org/~conikost/files/${PN}_${MY_PV}_tar.gz -> ${P}.tar.gz"
@@ -39,6 +41,9 @@ src_prepare() {
}
src_compile() {
+ # See bug 913410 for more information.
+ append-ldflags -z notext
+
if use arm; then
cd "${S}"/ARM || die
fi