summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-05-23 23:43:00 +0100
committerMarek Szuba <marecki@gentoo.org>2022-05-23 23:43:00 +0100
commitc9e3a1247d82bcb29b1d015cd676ec947219311e (patch)
treeb26ae759799e65b08c758f95c490af076492ddce /app-backup
parentdev-python/ruamel-std-pathlib: enable py3.11 (diff)
downloadgentoo-c9e3a1247d82bcb29b1d015cd676ec947219311e.tar.gz
gentoo-c9e3a1247d82bcb29b1d015cd676ec947219311e.tar.bz2
gentoo-c9e3a1247d82bcb29b1d015cd676ec947219311e.zip
app-backup/borgmatic: add 1.6.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.6.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 86dfa9ea8fd2..fff34c2d0ee2 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1 +1,2 @@
DIST borgmatic-1.5.24.tar.gz 291853 BLAKE2B d8c695c8faf713cd75e994d8ae7633674d01981047ce79d35d392b9db5a2dfb47c2be4a91e0f183ab2ead5877ee68983d0fdfd88ae7d28355d8029d39cbfdc04 SHA512 cfa1bd1dc6119497fba99d02e4f53322aede907ba8b30068b6c1dadc67f5e30466d2f1f0d83f1f15f71dfac08ef5b0adb376d24d62f1cd44992e7a45f99fde34
+DIST borgmatic-1.6.0.tar.gz 296751 BLAKE2B b3317fed0e497d3e51e5a52d9625514152673390859de08420ec80c850430892ebca12c01e9e9cfe3cd7ca15d753d44b4d421de88386f118432ddfb44516fc93 SHA512 7f1108da3ff26d23d1dbd3b7797ed31de19bfdca22af2f49b165694f36510c657fbd2dbe05f0f6e30a2eb69281157b139a5f5a7782e908899c73b4102444fcb3
diff --git a/app-backup/borgmatic/borgmatic-1.6.0.ebuild b/app-backup/borgmatic/borgmatic-1.6.0.ebuild
new file mode 100644
index 000000000000..f48f145dc769
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.6.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.5.16-systemd_service_bin_path.patch
+)
+
+# test_borgmatic_version_matches_news_version tries to run the 'borgmatic'
+# executable so making it work would require passing --install
+# to distutils_enable_tests. Given that this is the only test requiring
+# this and that all it does is make sure the NEWS file has been updated
+# for the current version, just skip it.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}