summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-10-31 11:24:27 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-10-31 11:24:27 -0500
commitef843f852b0a7a230ad9adaa1a56b404a64cd3c3 (patch)
tree129e125c4d52fa4ffabe5bea312b8d8add49458a /app-backup/restic
parentapp-backup/restic: add 0.16.2 (diff)
downloadgentoo-ef843f852b0a7a230ad9adaa1a56b404a64cd3c3.tar.gz
gentoo-ef843f852b0a7a230ad9adaa1a56b404a64cd3c3.tar.bz2
gentoo-ef843f852b0a7a230ad9adaa1a56b404a64cd3c3.zip
app-backup/restic: drop 0.16.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-backup/restic')
-rw-r--r--app-backup/restic/Manifest2
-rw-r--r--app-backup/restic/restic-0.16.0.ebuild47
2 files changed, 0 insertions, 49 deletions
diff --git a/app-backup/restic/Manifest b/app-backup/restic/Manifest
index cee67edce105..c1b6ab35d452 100644
--- a/app-backup/restic/Manifest
+++ b/app-backup/restic/Manifest
@@ -1,6 +1,4 @@
DIST restic-0.15.2-deps.tar.xz 159164476 BLAKE2B 652c5f880dc88ab9b4fcfb0168cf5bce19587f7c0195e379ac01ff227fd453bb5fc6ab72b7803d7070f92ea608a077aa0f79005f000b5626d7ea8841c9ec9643 SHA512 e4ef9ebfc09998e912128d84790081d16c05dad23e680f642e204974fc1ddd3a1f92ad2035227f6448f7661e24ba69379b1dc8198115d2d3d780ad0b0c7a475c
DIST restic-0.15.2.tar.gz 23924222 BLAKE2B d07f505a9d3a425c2fbad275f43a3a23e0b84b673e0ac77f52c45c2965266b483ae136fe99f0bc82903680ff0c5843edd1ed72e4864e5977c2ed2c85a703520c SHA512 8135f8a77c6f1264d962156f58fca4023da6581099cfd4a69379d8f1f137443c217c0207aeb7d41b603b341e78e9b3050c6bdad81323e0efd7b81805f33263bd
-DIST restic-0.16.0-vendor.tar.xz 3220044 BLAKE2B b3b27f397b440c59afe2c1f25346e243c51da4dbee53bfd5b5e113bc1c8c88bea328911fa8aaf5287989e5d4f5dfc7a28e0a3878cce172c18bcbdadc1aaa7abb SHA512 69f335d3cdd9b554b5f0b0255864854c2b3eb14c224f6474f3249be649faa1fa82b378c6c5582c09771771ccf8a12adb6ba527ccb2006606ca1724606366c849
-DIST restic-0.16.0.tar.gz 23972221 BLAKE2B f9f28cb5751265368583b8b1ac01fad591cccb13ae0a9c7b8b3d41329783230484d190d763223c2a43d57b001ddcb3cefbfb2a37cf00eaef7b49ddb2c9610375 SHA512 d51732b611407cc8ebc40c9acb45df8154f87ece26b37d32074b59f5cfb56cbcca71695036923a50739215426dce614fb32d8cd18c581d37dc10d8a25b8c95e5
DIST restic-0.16.2-deps.tar.xz 171734268 BLAKE2B 76ad6bcfeabeb39b31a413ebdac3a24181bd958502e2a4720343c23e078200b5c038c21acfbf3b23ae1d8302bf1af8b8a4a97467e2ffe5929b8d91250ca59fa3 SHA512 a0ebcb0ea0f0346d38bfa3b84f1fc9600a8d6fd4acad1819f8a292f3f00991d1f06f39f3e51884a4508329bfedc8f77ec63b6a3de0eae7dc7b15d54f14e93088
DIST restic-0.16.2.tar.gz 23981852 BLAKE2B a4feeb44a33d0a3291be04222dfb8939f0a9dbc74e72e10f1334994326ea9154351bc13825664956f0c288916c9455da3eac9a42483b49eb761a85faec67bced SHA512 319b0165def0a874b80314b8ff124a2460895660c55ebe5da260bfc92caeed0f0d886e9556043cfb3d83c1ca6b5f339ff5f74034989982f12c152505e347917c
diff --git a/app-backup/restic/restic-0.16.0.ebuild b/app-backup/restic/restic-0.16.0.ebuild
deleted file mode 100644
index ecaff989e08b..000000000000
--- a/app-backup/restic/restic-0.16.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module shell-completion
-
-DESCRIPTION="A backup program that is fast, efficient and secure"
-HOMEPAGE="https://restic.github.io/"
-SRC_URI="https://github.com/restic/restic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://gentoo.kropotkin.rocks/go-pkgs/${P}-vendor.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 LGPL-3-with-linking-exception MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-
-RDEPEND="sys-fs/fuse:0"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- local mygoargs=(
- -tags release
- -ldflags "-X main.version=${PV}"
- -asmflags "-trimpath=${S}"
- -gcflags "-trimpath=${S}"
- )
-
- ego build "${mygoargs[@]}" -o restic ./cmd/restic
-}
-
-src_test() {
- addwrite /dev/fuse
- # a number of the ./cmd/... tests fail
- # ego test -timeout 30m ./cmd/... ./internal/...
- RESTIC_TEST_FUSE=0 ego test -timeout 30m ./internal/...
-}
-
-src_install() {
- dobin restic
-
- newbashcomp doc/bash-completion.sh "${PN}"
- newzshcomp doc/zsh-completion.zsh _restic
- newfishcomp doc/fish-completion.fish "${PN}"
-
- doman doc/man/*
- dodoc doc/*.rst
-}