summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/tardy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/tardy')
-rw-r--r--app-arch/tardy/Manifest1
-rw-r--r--app-arch/tardy/files/tardy-1.28-test-utc.patch10
-rw-r--r--app-arch/tardy/metadata.xml11
-rw-r--r--app-arch/tardy/tardy-1.28.ebuild33
4 files changed, 55 insertions, 0 deletions
diff --git a/app-arch/tardy/Manifest b/app-arch/tardy/Manifest
new file mode 100644
index 000000000000..af09d7cef301
--- /dev/null
+++ b/app-arch/tardy/Manifest
@@ -0,0 +1 @@
+DIST tardy-1.28.D001.tar.gz 1848303 SHA256 79b4652a1d90745e131efcfc8512f4427b1388695036718938ec79fa5bc6c26f SHA512 d8f02d8a310cd3d84f89a67f3bf4e91689e33631b1701a98b70d32b801b1a7cafee5755f13ed18e31bb9d5b1ec147da21b13b57722e1bf15a9efc355ea5438df WHIRLPOOL 5e2db025e6243bb7f04ed1b39673e24fc7e3ef9c1c391c7c45fc55ae6aa5e689b9a26c3c8cc156c3f5364d496834902b6d0d77630e72a641360258b07c239fe4
diff --git a/app-arch/tardy/files/tardy-1.28-test-utc.patch b/app-arch/tardy/files/tardy-1.28-test-utc.patch
new file mode 100644
index 000000000000..3f15c38020e7
--- /dev/null
+++ b/app-arch/tardy/files/tardy-1.28-test-utc.patch
@@ -0,0 +1,10 @@
+--- tardy-1.28/test/00/t0075a.sh
++++ tardy-1.28/test/00/t0075a.sh
+@@ -19,6 +19,7 @@
+
+ TEST_SUBJECT="tarballs >2GB"
+ . test_prelude
++export TZ=UTC
+
+ # |||||
+ # beware potential timezone mismatch: vvvvv
diff --git a/app-arch/tardy/metadata.xml b/app-arch/tardy/metadata.xml
new file mode 100644
index 000000000000..4bc0f72ff7ab
--- /dev/null
+++ b/app-arch/tardy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Tardy is a tar post-processor for manipulating the file headers.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tardy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/tardy/tardy-1.28.ebuild b/app-arch/tardy/tardy-1.28.ebuild
new file mode 100644
index 000000000000..b887141ade7a
--- /dev/null
+++ b/app-arch/tardy/tardy-1.28.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A tar post-processor"
+HOMEPAGE="http://tardy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tardy/${P}.D001.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="app-arch/bzip2
+ app-arch/xz-utils
+ dev-libs/libexplain
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+src_prepare() {
+ sed -e 's/$(CXX) .* $(CXXFLAGS) -I./\0 -o $@/' \
+ -e '/mv \(.*\)\.o $@/d' \
+ -e '/@sleep 1/d' \
+ -e 's#^\(install-man: $(mandir)/man1/tardy.1\).*#\1#' \
+ -i Makefile.in || die
+
+ epatch "${FILESDIR}"/${P}-test-utc.patch
+ tc-export AR
+}