summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-10 00:07:44 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-10 00:58:15 +0200
commitd9267f69777e61a95edb723ae419da1703b1ee6c (patch)
treec6de0116ed675e1bf60d4b7433936d57a8bc7edf /app-arch/file-roller
parentapp-accessibility/orca: fix repoman complaint about metadata.xml indentation (diff)
downloadgentoo-d9267f69777e61a95edb723ae419da1703b1ee6c.tar.gz
gentoo-d9267f69777e61a95edb723ae419da1703b1ee6c.tar.bz2
gentoo-d9267f69777e61a95edb723ae419da1703b1ee6c.zip
app-arch/file-roller: version bump 3.22.3 → 3.24.1
Restore nautilus extension for file types not supported by nautilus. Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest1
-rw-r--r--app-arch/file-roller/file-roller-3.24.1.ebuild89
-rw-r--r--app-arch/file-roller/metadata.xml2
3 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index c6d78807555d..5f2dcc361023 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1 +1,2 @@
DIST file-roller-3.22.3.tar.xz 1423048 SHA256 de858640632a0e22769b6b73d5b98527f3cfc2c83f99692063e352e41d533505 SHA512 f234388686cf539fc085866322083199176f94043e4c2c888d5806a2efa0dfcf5a090f64240a3d08aae39ed3d34d6b281e1a06d748c56b0f80508a01fac40b28 WHIRLPOOL 9729c333d9d42d5714aa1fa9905f87f125e40c22800cd9cc85af67c31a90aad9863bd5a73aa659a0a5a997aacf638a9c974afbbc04541e90ee7d6c011e66e802
+DIST file-roller-3.24.1.tar.xz 1428216 SHA256 011545e8bd81a415fb068718347bf63ced4ab176210ce36a668904a3124c7f3a SHA512 bd8750b8ffe3e7d3c74492e2ffdde519e7879d46f16c559d06042bac60c8ee63f492aeeaa66b4aff7c997150f4f2955e02a3b0565edf4bd7641a089ed052f268 WHIRLPOOL 1d8c0d5fd1c2e7cc9cec0e02b44b252df2b3076bb83f553bf87cd89b7ffb9e116f320e52694413cbc80a1fe6287ff77b794b1af0a032a8687d0e22941813c34c
diff --git a/app-arch/file-roller/file-roller-3.24.1.ebuild b/app-arch/file-roller/file-roller-3.24.1.ebuild
new file mode 100644
index 000000000000..d0ee0fd3d696
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.24.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 readme.gentoo-r1
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+IUSE="libnotify nautilus packagekit"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/json-glib-0.14
+ >=x11-libs/gtk+-3.13.2:3
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ libnotify? ( >=x11-libs/libnotify-0.4.3:= )
+ nautilus? ( >=gnome-base/nautilus-2.22.2 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -f "${FILESDIR}"/3.22-packages.match data/packages.match || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ gnome2_src_configure \
+ --disable-run-in-place \
+ --disable-static \
+ --disable-debug \
+ --enable-magic \
+ --enable-libarchive \
+ $(use_enable libnotify notification) \
+ $(use_enable nautilus nautilus-actions) \
+ $(use_enable packagekit)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-arch/file-roller/metadata.xml b/app-arch/file-roller/metadata.xml
index 732e9f58dee9..f89b8750da80 100644
--- a/app-arch/file-roller/metadata.xml
+++ b/app-arch/file-roller/metadata.xml
@@ -6,6 +6,8 @@
<name>Gentoo GNOME Desktop</name>
</maintainer>
<use>
+ <flag name="nautilus">Build contextual menu extension for
+ <pkg>gnome-base/nautilus</pkg>.</flag>
<flag name="packagekit">Enable support for the distro-neutral package
manager GUI <pkg>app-admin/packagekit</pkg></flag>
</use>