summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-01-25 21:42:36 +1100
committerSam James <sam@gentoo.org>2023-03-07 12:14:51 +0000
commit45016f804905671dc3d5652290c8fb4eb7dc48bc (patch)
tree8d9b515ea6cf27b365d9b73c254ed11fa67445ba /app-arch/drpm
parentapp-crypt/gcr: fix implicit func decls (diff)
downloadgentoo-45016f804905671dc3d5652290c8fb4eb7dc48bc.tar.gz
gentoo-45016f804905671dc3d5652290c8fb4eb7dc48bc.tar.bz2
gentoo-45016f804905671dc3d5652290c8fb4eb7dc48bc.zip
app-arch/drpm: new package, add 0.5.1, 9999
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/drpm')
-rw-r--r--app-arch/drpm/Manifest1
-rw-r--r--app-arch/drpm/drpm-0.5.1.ebuild48
-rw-r--r--app-arch/drpm/drpm-9999.ebuild46
-rw-r--r--app-arch/drpm/files/drpm-0.5.1-c99.patch18
-rw-r--r--app-arch/drpm/metadata.xml18
5 files changed, 131 insertions, 0 deletions
diff --git a/app-arch/drpm/Manifest b/app-arch/drpm/Manifest
new file mode 100644
index 000000000000..13067f96a111
--- /dev/null
+++ b/app-arch/drpm/Manifest
@@ -0,0 +1 @@
+DIST drpm-0.5.1.tar.gz 138766 BLAKE2B dd64d925fa0e3975e2ca6f87fcddf10e376241d6b69a0f682cc5d6c006ef6aba7c021bcb98d049f4ce171b1561f36a07701e9eb47e0ac3c8315ee2d6d774c7c7 SHA512 5d4be3148075c6e0c560f97169a14e669a01ed48ef9228d8fc299b54da653ddec1110971a5b2bf455cc72cd1538d8c95e817428f73dd1d7ce07773822c05b3c5
diff --git a/app-arch/drpm/drpm-0.5.1.ebuild b/app-arch/drpm/drpm-0.5.1.ebuild
new file mode 100644
index 000000000000..8cb80e38d855
--- /dev/null
+++ b/app-arch/drpm/drpm-0.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A library for making, reading and applying deltarpm packages"
+HOMEPAGE="https://github.com/rpm-software-management/drpm"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rpm-software-management/drpm/"
+else
+ SRC_URI="https://github.com/rpm-software-management/drpm/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE="lzip test zstd"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/bzip2:=
+ app-arch/rpm
+ app-arch/xz-utils
+ dev-libs/openssl:=
+ sys-libs/zlib
+ lzip? ( app-arch/lzlib )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}
+ test? ( dev-util/cmocka )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-c99.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_LZLIB_DEVEL=$(usex lzip ON OFF)
+ -DWITH_ZSTD=$(usex zstd ON OFF)
+ -DENABLE_TESTS=$(usex test ON OFF)
+ )
+
+ cmake_src_configure
+}
diff --git a/app-arch/drpm/drpm-9999.ebuild b/app-arch/drpm/drpm-9999.ebuild
new file mode 100644
index 000000000000..668173c3e540
--- /dev/null
+++ b/app-arch/drpm/drpm-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A library for making, reading and applying deltarpm packages"
+HOMEPAGE="https://github.com/rpm-software-management/drpm"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rpm-software-management/drpm/"
+else
+ SRC_URI="https://github.com/rpm-software-management/drpm/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE="lzip test zstd"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/bzip2:=
+ app-arch/rpm
+ app-arch/xz-utils
+ dev-libs/openssl:=
+ sys-libs/zlib
+ lzip? ( app-arch/lzlib )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}
+ test? ( dev-util/cmocka )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_LZLIB_DEVEL=$(usex lzip ON OFF)
+ -DWITH_ZSTD=$(usex zstd ON OFF)
+ -DENABLE_TESTS=$(usex test ON OFF)
+ )
+
+ cmake_src_configure
+}
diff --git a/app-arch/drpm/files/drpm-0.5.1-c99.patch b/app-arch/drpm/files/drpm-0.5.1-c99.patch
new file mode 100644
index 000000000000..208284f53cff
--- /dev/null
+++ b/app-arch/drpm/files/drpm-0.5.1-c99.patch
@@ -0,0 +1,18 @@
+https://github.com/rpm-software-management/drpm/commit/0bde9b7711a2fa8b811830cadfc979365f9362c6
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 12 Jan 2023 08:17:19 +0100
+Subject: [PATCH] C99 compatibility fix for drpm_write.c
+
+Include <string.h> for various string functions. This avoids
+implicit function declarations and resulting build failures with
+future compilers.
+--- a/src/drpm_write.c
++++ b/src/drpm_write.c
+@@ -23,6 +23,7 @@
+
+ #include <stdio.h>
+ #include <stdint.h>
++#include <string.h>
+ #include <fcntl.h>
+ #include <openssl/md5.h>
+ #include <rpm/rpmlib.h>
diff --git a/app-arch/drpm/metadata.xml b/app-arch/drpm/metadata.xml
new file mode 100644
index 000000000000..b43a6f0c5f62
--- /dev/null
+++ b/app-arch/drpm/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="lzip">Enable <pkg>app-arch/lzip</pkg> decompression support via <pkg>app-arch/lzlib</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">rpm-software-management/drpm</remote-id>
+ </upstream>
+</pkgmetadata>