summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-07 04:07:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-07 04:07:49 +0200
commit8036adebd974457ba1572628c4a8cd2036b78d00 (patch)
tree927498f699c2a7cb553b1575add143335c761392 /app-admin
parentdev-python/boto3: Bump to 1.28.42 (diff)
downloadgentoo-8036adebd974457ba1572628c4a8cd2036b78d00.tar.gz
gentoo-8036adebd974457ba1572628c4a8cd2036b78d00.tar.bz2
gentoo-8036adebd974457ba1572628c4a8cd2036b78d00.zip
app-admin/awscli: Bump to 1.29.42
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.29.42.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 2818d598ac47..1937227bbd71 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.29.38.gh.tar.gz 2514130 BLAKE2B 520d86ecc116ac106b480eea03e71ac89
DIST aws-cli-1.29.39.gh.tar.gz 2515251 BLAKE2B 64324482a795d1d537953da21717faf952cd59b1473186cead596577f7089efb77a5803e5c57183ea5223ab10bc77910d0a13b6e94597e389ff09088e4df72b6 SHA512 aa1092cd35e4cb71cc7568bdde1bc3dbae5999b07f977bda0ade6fab00f87d825f8fe8165e241b3185d149d652684c725c1ad43260bf848d94cb61e8a46d16bd
DIST aws-cli-1.29.40.gh.tar.gz 2515692 BLAKE2B 1d7b93da39719ddd4813973f9b06f9f979ee043d81135585da627d2894254d8f200b9da9d29754a9270fecf948c47c97f3209ea47d5365a6af5d2a78526f6a07 SHA512 f0c55077f2e7f87990b0304269fe93835574701eb533569f773be407e9b3d0cca671b699911d9e2c728bd9c2181c298a92eb4f4a791d940964e52e66fa493863
DIST aws-cli-1.29.41.gh.tar.gz 2516949 BLAKE2B ae8b2c2c47b72832a038e883fdc6e15d2b59ac520203a21a1093f29d84131d054457700e59d3184768d1040f84708a73c4dac85fe2b1e99e121924c03f9b1ded SHA512 c48d16c577d4d3ac1038f33c716db6b9a61241a595b37105cde0841c84a3157f3004aaf8fd1ff95ef9b64837f8ab4c50cd875cd36154b4285bf01315b817b283
+DIST aws-cli-1.29.42.gh.tar.gz 2517766 BLAKE2B 88f70820385eb6930b8f4cc3724c3823019ce3de419689a7d2b400ec1ee66cb76d325cfc2ad6d5ad740003f2ce53fff198f470e69b79697f17b52430e8cc704c SHA512 3e37c45189531045a44e9b6295a1618f3fa321c89681956e362dc7675e94616a33734e8aa644e6e2236f72979bd8f1a7ce5d95e70f684bb14c2e9a5bd1c2aefb
diff --git a/app-admin/awscli/awscli-1.29.42.ebuild b/app-admin/awscli/awscli-1.29.42.ebuild
new file mode 100644
index 000000000000..b11b8e9f8900
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.42.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}