summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Oberzalek <kingleo@gmx.at>2022-07-27 09:49:02 +0200
committerSam James <sam@gentoo.org>2022-07-27 09:18:11 +0100
commit3c84321186d4ede4fac566257cd92c3e0189f02f (patch)
tree76b0156dab22e8be332ca65d50e3e1cc59d5b9db /app-admin
parentnet-libs/xrootd: different USE flag for the test suite (diff)
downloadgentoo-3c84321186d4ede4fac566257cd92c3e0189f02f.tar.gz
gentoo-3c84321186d4ede4fac566257cd92c3e0189f02f.tar.bz2
gentoo-3c84321186d4ede4fac566257cd92c3e0189f02f.zip
app-admin/xstow: add 1.1.0
new upstream release xstow-1.1.0 Signed-off-by: Martin Oberzalek <kingleo@gmx.at> Closes: https://github.com/gentoo/gentoo/pull/26616 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/xstow/Manifest1
-rw-r--r--app-admin/xstow/files/xstow-1.1.0-clang.patch48
-rw-r--r--app-admin/xstow/xstow-1.1.0.ebuild53
3 files changed, 102 insertions, 0 deletions
diff --git a/app-admin/xstow/Manifest b/app-admin/xstow/Manifest
index de84b67bb529..de4aba8d61de 100644
--- a/app-admin/xstow/Manifest
+++ b/app-admin/xstow/Manifest
@@ -1 +1,2 @@
DIST xstow-1.0.2.tar.bz2 151622 BLAKE2B 45123c2cb018605c2e47940707384ea1824ddf4f542cfad6a73bfc3559803ca6ec7811252221ad80125e1821cac6d65bcc106b4acf294c4fa453e8043c78cf04 SHA512 319dcd57290fcee9fd66811e64af73ddab8abb11d47c0cb79d3e11f1ecdf18ab9511b3a0690621061d2613193cd4895f3bddb3d741159c23c14d278a8a8bf9dd
+DIST xstow-1.1.0.tar.bz2 187761 BLAKE2B ed3822e638aedf8900a3baba62a5af9de9d7b98dcdf27ca81a6898353b9f5c7f767ec7d8e68ead4d5ef318af5a6eda2b1cc68a5c80a6a8ad2b9c8adf03ae3377 SHA512 30f2e0be0c2aba668b4cc781fe69ac74c2460cc681c6b47a55ee66af5c0f2ac14dee9fe2e95a288ce06059378407a2b99d2156430a5a6dcbf06def793f579015
diff --git a/app-admin/xstow/files/xstow-1.1.0-clang.patch b/app-admin/xstow/files/xstow-1.1.0-clang.patch
new file mode 100644
index 000000000000..dc85f734aff4
--- /dev/null
+++ b/app-admin/xstow/files/xstow-1.1.0-clang.patch
@@ -0,0 +1,48 @@
+From bdcbdb6f6e0f35ed0a0df50f0a9d19441af9c866 Mon Sep 17 00:00:00 2001
+From: Martin Oberzalek <kingleo@gmx.at>
+Date: Wed, 27 Jul 2022 09:25:03 +0200
+Subject: [PATCH] Fixed compilation with clang
+
+---
+ src/cpputils/cpputilsshared/cpputilsformat/format2.h | 2 +-
+ src/cpputils/cpputilsshared/leoini.h | 11 +++++------
+ 2 files changed, 6 insertions(+), 7 deletions(-)
+
+diff --git a/src/cpputils/cpputilsshared/cpputilsformat/format2.h b/src/cpputils/cpputilsshared/cpputilsformat/format2.h
+index eb084e2..b3d7624 100644
+--- a/src/cpputils/cpputilsshared/cpputilsformat/format2.h
++++ b/src/cpputils/cpputilsshared/cpputilsformat/format2.h
+@@ -40,7 +40,7 @@ namespace Tools {
+ bool _is_string;
+
+ public:
+- BaseArg( bool is_int_, bool is_string_ )
++ BaseArg( bool is_int_ = false, bool is_string_ = false )
+ : _is_int( is_int_ ),
+ _is_string( is_string_ )
+ {}
+diff --git a/src/cpputils/cpputilsshared/leoini.h b/src/cpputils/cpputilsshared/leoini.h
+index ee77511..0ad8493 100644
+--- a/src/cpputils/cpputilsshared/leoini.h
++++ b/src/cpputils/cpputilsshared/leoini.h
+@@ -278,12 +278,11 @@ namespace Leo
+ std::string::size_type end = s.find( ']', start );
+
+ if( start == std::string::npos ||
+- end == std::string::npos )
+- s = "";
+- else
+- s = s.substr( start+1, start-end -1 );
+-
+- return s2x<A>(s);
++ end == std::string::npos ) {
++ return s2x<A>("");
++ } else {
++ return s2x<A>( s.substr( start+1, start-end -1 ) );
++ }
+ }
+ } // namespace Leo
+
+--
+2.35.1
+
diff --git a/app-admin/xstow/xstow-1.1.0.ebuild b/app-admin/xstow/xstow-1.1.0.ebuild
new file mode 100644
index 000000000000..99fc63fb1425
--- /dev/null
+++ b/app-admin/xstow/xstow-1.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Replacement for GNU stow with extensions"
+HOMEPAGE="http://xstow.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xstow/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ncurses"
+
+DEPEND="ncurses? ( sys-libs/ncurses:0= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/xstow-1.1.0-clang.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with ncurses curses)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ # Create new STOWDIR
+ keepdir /var/lib/xstow
+
+ # Install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}"/99xstow
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/xstow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264"
+ elog "(regarding app-admin/stow, equally applicable to XStow) for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/bin."
+}