summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-07 12:59:03 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-07 13:00:22 -0500
commitec196793931d17a8454945741ea3ac531873925b (patch)
treed9c6d2a8f62c16111239ef507c26a5d8f7b0cb96 /app-admin/tmpwatch
parentapp-admin/pydf: bump to EAPI 6, add maintainer-needed (diff)
downloadgentoo-ec196793931d17a8454945741ea3ac531873925b.tar.gz
gentoo-ec196793931d17a8454945741ea3ac531873925b.tar.bz2
gentoo-ec196793931d17a8454945741ea3ac531873925b.zip
app-admin/tmpwatch: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-admin/tmpwatch')
-rw-r--r--app-admin/tmpwatch/metadata.xml1
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/tmpwatch/metadata.xml b/app-admin/tmpwatch/metadata.xml
index 097975e3adc2..6f49eba8f496 100644
--- a/app-admin/tmpwatch/metadata.xml
+++ b/app-admin/tmpwatch/metadata.xml
@@ -1,4 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<!-- maintainer-needed -->
</pkgmetadata>
diff --git a/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild b/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
new file mode 100644
index 000000000000..3de93527fc08
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.11-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Files which haven't been accessed in a given period of time are removed from specified directories"
+HOMEPAGE="https://fedorahosted.org/tmpwatch/"
+SRC_URI="https://fedorahosted.org/releases/t/m/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-tmpreaper )"
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-boottime.patch"
+)
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dosbin tmpwatch
+ doman tmpwatch.8
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}"
+}