summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/tmpwatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/tmpwatch')
-rw-r--r--app-admin/tmpwatch/Manifest1
-rw-r--r--app-admin/tmpwatch/files/tmpwatch-2.11-boottime.patch30
-rw-r--r--app-admin/tmpwatch/files/tmpwatch.cron48
-rw-r--r--app-admin/tmpwatch/metadata.xml8
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild37
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.11.ebuild32
6 files changed, 156 insertions, 0 deletions
diff --git a/app-admin/tmpwatch/Manifest b/app-admin/tmpwatch/Manifest
new file mode 100644
index 000000000000..ca22cfe03d8c
--- /dev/null
+++ b/app-admin/tmpwatch/Manifest
@@ -0,0 +1 @@
+DIST tmpwatch-2.11.tar.bz2 145609 SHA256 93168112b2515bc4c7117e8113b8d91e06b79550d2194d62a0c174fe6c2aa8d4 SHA512 9242c5e1812c2ffc756cfc4cdc3023d0c0515e7c180e58ca3a838aa075d09fe4dc08dbc9afbc87ce3382e8aa8cb80a70e406deeab4ce10b39b6845d667989d97 WHIRLPOOL 94d83c4a2b1c1a19ab88632c61de37903b709bc7fa88aff9f8ac4f4b71a26b8e6fbcb1564b3bce08ed5d1d0a78511c3470978a13211356f5fdf10b4d40f2de1c
diff --git a/app-admin/tmpwatch/files/tmpwatch-2.11-boottime.patch b/app-admin/tmpwatch/files/tmpwatch-2.11-boottime.patch
new file mode 100644
index 000000000000..b622c8d70e70
--- /dev/null
+++ b/app-admin/tmpwatch/files/tmpwatch-2.11-boottime.patch
@@ -0,0 +1,30 @@
+Make boot time detection failures non-fatal. Taken from PLD Linux
+
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=468444
+PLD bug: https://bugs.launchpad.net/pld-linux/+bug/1034364
+Patch: https://github.com/pld-linux/tmpwatch/blob/master/tmpwatch-boottime.patch
+
+--- tmpwatch-2.11/tmpwatch.c~
++++ tmpwatch-2.11/tmpwatch.c
+@@ -666,9 +666,11 @@
+ time_t boot_time;
+
+ if (clock_gettime(CLOCK_REALTIME, &real_clock) != 0
+- || clock_gettime(CLOCK_BOOTTIME, &boot_clock) != 0)
+- message(LOG_FATAL, "Error determining boot time: %s\n",
++ || clock_gettime(CLOCK_BOOTTIME, &boot_clock) != 0) {
++ message(LOG_DEBUG, "Error determining boot time: %s\n",
+ strerror(errno));
++ socket_kill_time = 0; /* Never remove sockets */
++ } else {
+ boot_time = real_clock.tv_sec - boot_clock.tv_sec;
+ if (real_clock.tv_nsec < boot_clock.tv_nsec)
+ boot_time--;
+@@ -677,6 +679,7 @@
+ boot_time -= 2;
+
+ socket_kill_time = boot_time - grace_seconds;
++ }
+ #else
+ socket_kill_time = 0; /* Never remove sockets */
+ #endif
diff --git a/app-admin/tmpwatch/files/tmpwatch.cron b/app-admin/tmpwatch/files/tmpwatch.cron
new file mode 100644
index 000000000000..95634ba16c78
--- /dev/null
+++ b/app-admin/tmpwatch/files/tmpwatch.cron
@@ -0,0 +1,48 @@
+#!/bin/sh
+# $Id$
+# vim: ft=sh
+
+# This cron script contains several (commented out) examples. You may use
+# them as is, by uncommenting them, or modify them to suit your needs. Read
+# tmpwatch(8) for more information on tmpwatch parameters.
+
+### Variables ###
+
+TMPWATCH="/usr/sbin/tmpwatch"
+#PORTAGE_TMPDIR="$(portageq envvar PORTAGE_TMPDIR)/portage"
+#PORTAGE_LOGDIR="$(portageq envvar PORT_LOGDIR)"
+#DISTDIR="$(portageq distdir)"
+
+### EXAMPLES ###
+
+# NOTE: if you have noatime in /etc/fstab for any partitions you plan on
+# running tmpwatch on, you should obviously change any of the examples that
+# use atime (-u|--atime). Those that don't specify anything, default to
+# atime.
+
+# NOTE2: the time value is in HOURS!
+
+# Delete everything in /tmp that haven't been accessed in a week (>=168 hrs).
+#
+# if [[ -d /tmp ]]; then
+# ${TMPWATCH} --atime 168 /tmp
+# fi
+
+# Delete everything in PORTAGE_TMPDIR that hasn't been modified in 2 weeks.
+#
+# if [[ -d ${PORTAGE_TMPDIR:-/var/tmp/portage} && -z $(/usr/bin/pgrep emerge) ]]; then
+# ${TMPWATCH} --mtime --all 336 ${PORTAGE_TMPDIR:-/var/tmp/portage}
+# fi
+
+# Delete everything in DISTDIR that hasn't been accessed in 6 months (going
+# by 30 day months)
+#
+# if [[ -d ${DISTDIR:-/usr/portage/distfiles} ]]; then
+# ${TMPWATCH} --atime --fuser 4320 ${DISTDIR:-/usr/portage/distfiles}
+# fi
+
+# Delete everything in PORTAGE_LOGDIR that hasn't been accessed in 4 weeks
+#
+# if [[ -d ${PORTAGE_LOGDIR:-/var/log/portage} ]]; then
+# ${TMPWATCH} --atime 772 ${PORTAGE_LOGDIR:-/var/log/portage}
+# fi
diff --git a/app-admin/tmpwatch/metadata.xml b/app-admin/tmpwatch/metadata.xml
new file mode 100644
index 000000000000..7af4418d46d2
--- /dev/null
+++ b/app-admin/tmpwatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>fauli@gentoo.org</email>
+ <name>Christian Faulhammer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild b/app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild
new file mode 100644
index 000000000000..5a300e412916
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.11-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Files which haven't been accessed in a given period of time are removed from specified directories"
+HOMEPAGE="https://fedorahosted.org/tmpwatch/"
+SRC_URI="https://fedorahosted.org/releases/t/m/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-tmpreaper )"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-boottime.patch"
+ epatch_user
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ dosbin tmpwatch || die
+ doman tmpwatch.8 || die
+ dodoc ChangeLog NEWS README AUTHORS || die
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}" || die
+}
diff --git a/app-admin/tmpwatch/tmpwatch-2.11.ebuild b/app-admin/tmpwatch/tmpwatch-2.11.ebuild
new file mode 100644
index 000000000000..64b9f553c4a5
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Files which haven't been accessed in a given period of time are removed from specified directories"
+HOMEPAGE="https://fedorahosted.org/tmpwatch/"
+SRC_URI="https://fedorahosted.org/releases/t/m/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-tmpreaper )"
+DEPEND=""
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ dosbin tmpwatch || die
+ doman tmpwatch.8 || die
+ dodoc ChangeLog NEWS README AUTHORS || die
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}" || die
+}