summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-26 14:30:42 +0000
committerSam James <sam@gentoo.org>2021-04-26 15:37:19 +0000
commitce410251339bf6d66d9ce2f3e42f359dce1a87b1 (patch)
treeb7349ad06655ffacbc9aae50c8c9494f9b93c4a1 /app-admin/stow
parentapp-crypt/openpgp-keys-adamspiers: initial import (diff)
downloadgentoo-ce410251339bf6d66d9ce2f3e42f359dce1a87b1.tar.gz
gentoo-ce410251339bf6d66d9ce2f3e42f359dce1a87b1.tar.bz2
gentoo-ce410251339bf6d66d9ce2f3e42f359dce1a87b1.zip
app-admin/stow: add verify-sig support
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/stow')
-rw-r--r--app-admin/stow/Manifest1
-rw-r--r--app-admin/stow/stow-2.3.1.ebuild9
2 files changed, 7 insertions, 3 deletions
diff --git a/app-admin/stow/Manifest b/app-admin/stow/Manifest
index 82aa4345f972..46ed86de6b19 100644
--- a/app-admin/stow/Manifest
+++ b/app-admin/stow/Manifest
@@ -1 +1,2 @@
DIST stow-2.3.1.tar.gz 654191 BLAKE2B 9fd54fd3ff76aa7b72ed973cd6d70b8dc747fa3bb1ecc6bedd221b308d7d141a21a2f077c67efb432f2c7c4fb6bd126639038b196946206bf4a7f95040477ab2 SHA512 e9a7de1a6f10eaf7cdbe6737e0a8be1498e2eac46b6c57e65b83759b061efd1c0db45f7cba123e35428307e3aebe5baef9ea8bd4b5eb6ec5e1b159117a760441
+DIST stow-2.3.1.tar.gz.sig 833 BLAKE2B 9c4e3d5f59f793b629e27fccda6dd6c8934b3055b4104a6452dda866908c89c11845f9da68b1cfa78662421f1642c27c2d5957042d861be26951ca78203b1c2a SHA512 87cf2cb3a5be9b80edb2a4f6ec97e193d67b1301edb87664fec6d3b51a1bedd2635fcddd92825a1efeb383cad3c06662f436d3c9b301e73862775f44b324fff5
diff --git a/app-admin/stow/stow-2.3.1.ebuild b/app-admin/stow/stow-2.3.1.ebuild
index 699d43644d50..85cbb9866c54 100644
--- a/app-admin/stow/stow-2.3.1.ebuild
+++ b/app-admin/stow/stow-2.3.1.ebuild
@@ -3,11 +3,13 @@
EAPI=7
-inherit perl-functions
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/adamspiers.asc
+inherit perl-functions verify-sig
DESCRIPTION="GNU Stow is a symlink farm manager"
HOMEPAGE="https://www.gnu.org/software/stow/ https://git.savannah.gnu.org/cgit/stow.git"
SRC_URI="mirror://gnu/stow/${P}.tar.gz"
+SRC_URI+=" verify-sig? ( mirror://gnu/stow/${P}.tar.gz.sig )"
LICENSE="GPL-3+"
SLOT="0"
@@ -16,13 +18,14 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-lang/perl:="
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
dev-perl/IO-stringy
virtual/perl-Test-Harness
dev-perl/Test-Output
)
+ verify-sig? ( app-crypt/openpgp-keys-adamspiers )
"
src_configure() {