summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-09-10 17:40:42 -0600
committerSam James <sam@gentoo.org>2023-09-13 04:48:03 +0100
commita86b668a88739586feda1e39635e2c533105d14e (patch)
tree1046dca454a7d1afbf990868cec1d1f096caddb2 /app-admin/ide-smart
parentapp-admin/gentoo-perl-helpers: update EAPI 6 -> 8 (diff)
downloadgentoo-a86b668a88739586feda1e39635e2c533105d14e.tar.gz
gentoo-a86b668a88739586feda1e39635e2c533105d14e.tar.bz2
gentoo-a86b668a88739586feda1e39635e2c533105d14e.zip
app-admin/ide-smart: update EAPI 6 -> 8
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/ide-smart')
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/ide-smart/ide-smart-1.4-r3.ebuild b/app-admin/ide-smart/ide-smart-1.4-r3.ebuild
new file mode 100644
index 000000000000..813ff8c814dc
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="A tool to read SMART information from harddiscs"
+HOMEPAGE="http://www.linalco.com/comunidad.html http://www.linux-ide.org/smart.html"
+SRC_URI="http://www.linalco.com/ragnar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_compile() {
+ edo $(tc-getCC) ${CFLAGS} ${CPPFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c
+}
+
+src_install() {
+ dobin ide-smart
+ doman ide-smart.8
+ dodoc README
+}