summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-11-14 10:45:01 +0100
committerAgostino Sarubbo <ago@gentoo.org>2022-11-14 10:45:01 +0100
commite47cbcf74ce78dfae1217760b4010fede5981061 (patch)
tree6a54e45e7a4ad7f4a6646c9a902d429a1d32fa2a /app-admin/hcloud
parentdev-python/networkx: Keyword 2.8.8 ia64, #862330 (diff)
downloadgentoo-e47cbcf74ce78dfae1217760b4010fede5981061.tar.gz
gentoo-e47cbcf74ce78dfae1217760b4010fede5981061.tar.bz2
gentoo-e47cbcf74ce78dfae1217760b4010fede5981061.zip
app-admin/hcloud: version bump to 1.30.4
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/hcloud')
-rw-r--r--app-admin/hcloud/Manifest1
-rw-r--r--app-admin/hcloud/hcloud-1.30.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/hcloud/Manifest b/app-admin/hcloud/Manifest
index 61880caaecf2..3b11ef0ec8c4 100644
--- a/app-admin/hcloud/Manifest
+++ b/app-admin/hcloud/Manifest
@@ -1 +1,2 @@
DIST hcloud-1.30.3.tar.xz 1690980 BLAKE2B 115a6769d5bd5e6a10d812502506f9921a7659a262eea7088c88205e9fc748a570c1c9830e5061923f1be18a64d96104e6e930c9edc3316645e5d86450fbf69c SHA512 64bc692b8d098149815ba63aec8346a7f4f2ff7461fac3369343595a733a5c727b41ec8341e4eee1a98804b14bfc5a94ff9fc0621abb798d381d9bc802818b77
+DIST hcloud-1.30.4.tar.xz 1727416 BLAKE2B 004c15b773a64e936914a54b6b151745c56da6364ef010513b51696269363ff240205aefa54f6c7eb59e875a4b4a580666811153fffeaeb9c37577f53620ff8c SHA512 b34fa778c75ca070b2feb73279042ba796fdfcdf9ff33a52f854315cafc2e6c7f266ba602c29bfa08981ccfd91984c9b8f1fcdb0a6b761412ee18a23818c0bac
diff --git a/app-admin/hcloud/hcloud-1.30.4.ebuild b/app-admin/hcloud/hcloud-1.30.4.ebuild
new file mode 100644
index 000000000000..82ba00ab5dca
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.30.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/internal/version.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
+}
+
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}