summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-23 07:21:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-23 08:09:47 +0100
commit610d5f692e0f2f39097d6166881fd654df92e9ae (patch)
treec65ad25d0c2293f218fca703e30b547bd3ff5226 /app-admin/awscli
parentdev-python/boto3: Bump to 1.35.68 (diff)
downloadgentoo-610d5f692e0f2f39097d6166881fd654df92e9ae.tar.gz
gentoo-610d5f692e0f2f39097d6166881fd654df92e9ae.tar.bz2
gentoo-610d5f692e0f2f39097d6166881fd654df92e9ae.zip
app-admin/awscli: Bump to 1.36.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.36.9.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 799ce6176683..b336074fe4c0 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.36.5.gh.tar.gz 2826720 BLAKE2B fc1fae0f6983c635e27a98747dc9cdf7b4
DIST aws-cli-1.36.6.gh.tar.gz 2827814 BLAKE2B 23089b5c996a298b1a9cc529701f9ad25d5794b81e1bfdf952db829dd3d57ec2c5229f81fe071d6ef4e9d050b55766d3abb38a40ff10bb91dbb882c39dd2c68a SHA512 a02725703fe7cab1b55683a1cd9b7fcb4ca9fe7deedd7b867b52a9164af6522fe25be8da6ee1858708ad3a9e20f134155b70cc87d8c87d5df167336dc8539de0
DIST aws-cli-1.36.7.gh.tar.gz 2830849 BLAKE2B 97dc3fe17c64e241d8bee007664e5c10feea87f799f6c4659883da1f85fb12610d46e77ed58cb884656a3b2ff89dd51e0f7d2bcc5ac8947b45c517a06d5f815e SHA512 bf8cfc09c0c3948d778d5ad9cdb5638f7b3ea7ac34c9e63e98a46fa06c651bc5798076a35229506f272b6b0160165bbea69beea5497989b70b6d2d2bc86334c8
DIST aws-cli-1.36.8.gh.tar.gz 2833023 BLAKE2B e19765639c8f9c3c2b2faa607391ff48a75ce57d0d8d612caae577c81c3d26a5adc501304f6a2ef250d9b9841813495f24701c3b794d612c6d2903b88ffee4e5 SHA512 556bf9f8e26e620517a1fd7c907158a5d5ff49ea25987ccbacb7030c2f80aa45d63fff36327e30dce4a1b8f9030f5205788b3995027d920a49c56c45c2f9fe1b
+DIST aws-cli-1.36.9.gh.tar.gz 2836018 BLAKE2B aada8a63f5bedd5aeeddd56fe18bb49ae1763ba5c737f72aa2f2e00b57fa4e1ab52ec266ca6883859ec633ec2b1658383426809870ba1372d86f9d8e0a055ac6 SHA512 ec47c26012027071732d60f9bd8b3322c1c75b2362dffe7affd8cd6d70732e6239bfbb6531759a247bcb2f29613a88b196d10f405302d25a05ada7968bd7574e
diff --git a/app-admin/awscli/awscli-1.36.9.ebuild b/app-admin/awscli/awscli-1.36.9.ebuild
new file mode 100644
index 000000000000..2960403cf7e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.9.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}