summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-09-22 22:59:38 -0300
committerPacho Ramos <pacho@gentoo.org>2024-11-09 13:29:00 +0100
commitfc39c325d7d276688de7735c0fe24fa266865be7 (patch)
tree9760b7366ff293ad006ed353bc263895c1021609 /app-accessibility
parentapp-text/iso-codes: Reorder variables (diff)
downloadgentoo-fc39c325d7d276688de7735c0fe24fa266865be7.tar.gz
gentoo-fc39c325d7d276688de7735c0fe24fa266865be7.tar.bz2
gentoo-fc39c325d7d276688de7735c0fe24fa266865be7.zip
app-accessibility/accerciser: Bump to 3.44.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38735 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/accerciser/Manifest1
-rw-r--r--app-accessibility/accerciser/accerciser-3.44.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
index b3f4b577c1ef..412445435804 100644
--- a/app-accessibility/accerciser/Manifest
+++ b/app-accessibility/accerciser/Manifest
@@ -1 +1,2 @@
DIST accerciser-3.42.0.tar.xz 1999644 BLAKE2B 190f37ab94aba2dd1f16594242426a33bac366b89eb284c739c02a96cf0330ccb562237079d79ade5b729c5e38facbb542af2ace195a5d9b6d1c68a5005ba653 SHA512 65c3819c80c9ec3c8728963572a2c7bb4575782abde8ee34e3b7fa31217ef0e8106a7702c5b5a32b123ccb84b357984844a6d4aee75bf7e6157f3d63588224da
+DIST accerciser-3.44.1.tar.xz 1784476 BLAKE2B e4bb24cf13b54ee15f400db78b55bc091edfa7c75b7bd0fb775c32c8c0a77fb0d50962c99d777f45a131fb904c1cc8e667739b41fb51aef52cbebce746c9622b SHA512 5b1db506260a459c01e6245de76b18c90ed4dd7a325c63a692cb9f31daf125986b50555e2577ccbcaa85f21d5bfce4c275adcd0710c4f1ff697c356ba9198684
diff --git a/app-accessibility/accerciser/accerciser-3.44.1.ebuild b/app-accessibility/accerciser/accerciser-3.44.1.ebuild
new file mode 100644
index 000000000000..71c845b20ff2
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.44.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser https://gitlab.gnome.org/GNOME/accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=x11-libs/gtk+-3.24.0:3[introspection]
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ ')
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection:=
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ gnome-base/librsvg[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+
+src_install() {
+ python_fix_shebang "${WORKDIR}/${P}-build"/src/accerciser
+ meson_src_install
+ gnome2_src_install
+ python_optimize
+}