summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/epos
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/epos')
-rw-r--r--app-accessibility/epos/Manifest1
-rw-r--r--app-accessibility/epos/epos-2.5.37-r1.ebuild43
-rw-r--r--app-accessibility/epos/files/README.gentoo2
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-disable-tests.patch16
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc43.patch23
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc45.patch15
-rw-r--r--app-accessibility/epos/files/epos-2.5.37-gcc47.patch16
-rw-r--r--app-accessibility/epos/files/eposd21
-rw-r--r--app-accessibility/epos/metadata.xml8
9 files changed, 145 insertions, 0 deletions
diff --git a/app-accessibility/epos/Manifest b/app-accessibility/epos/Manifest
new file mode 100644
index 000000000000..0d27ef422555
--- /dev/null
+++ b/app-accessibility/epos/Manifest
@@ -0,0 +1 @@
+DIST epos-2.5.37.tar.gz 976240 SHA256 7b6e835d4db4f64cfdcf3359d84b6b0ed02e8fb89851aed7615768f7d07c8607 SHA512 870718a5e7b5048eafd62c478963de92fe8a90b3e755f79ea665dc33ad762c0ec4ebaf7c99d5f2be8983a0deacba284ae07b24d9a31bdd1a1eff5924327255ef WHIRLPOOL 874657f4f9435d6fed821747229758e2f064ed467dae418a085c5d2268aa2ac1b22ba55bbd393ecd7a08d4332d1ee742e2b032abfa99b2ff1c9d06cc26b851c1
diff --git a/app-accessibility/epos/epos-2.5.37-r1.ebuild b/app-accessibility/epos/epos-2.5.37-r1.ebuild
new file mode 100644
index 000000000000..4cd66ace9d2a
--- /dev/null
+++ b/app-accessibility/epos/epos-2.5.37-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="language independent text-to-speech system"
+HOMEPAGE="http://epos.ure.cas.cz/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND=">=app-text/sgmltools-lite-3.0.3-r9"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc45.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-disable-tests.patch
+
+ sed -i -e "s/CCC/#CCC/" configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-charsets \
+ --disable-portaudio
+}
+
+src_install() {
+ default
+
+ doinitd "${FILESDIR}/eposd"
+ dodoc WELCOME THANKS Changes "${FILESDIR}/README.gentoo"
+}
diff --git a/app-accessibility/epos/files/README.gentoo b/app-accessibility/epos/files/README.gentoo
new file mode 100644
index 000000000000..a058564ea278
--- /dev/null
+++ b/app-accessibility/epos/files/README.gentoo
@@ -0,0 +1,2 @@
+Due to /usr/bin/say conflicting with the speech-dispatcher ebuild, it has
+beenn moved to /usr/bin/epos_say.
diff --git a/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch b/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch
new file mode 100644
index 000000000000..a877ca68486b
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-disable-tests.patch
@@ -0,0 +1,16 @@
+diff -uNr epos-2.5.37.org/src/tests/Makefile.am epos-2.5.37/src/tests/Makefile.am
+--- epos-2.5.37.org/src/tests/Makefile.am 2012-04-14 00:38:56.000000000 -0400
++++ epos-2.5.37/src/tests/Makefile.am 2012-04-14 00:39:10.000000000 -0400
+@@ -1,11 +1,9 @@
+ ## Process this file with automake run in the top directory to yield Makefile.in
+
+ TESTS=hard_zero_data_test \
+- intr_test \
+- legal_data_test long_data_test long_strm_test \
++ legal_data_test long_data_test \
+ random_data_test \
+ soft_zero_data_test \
+- syn2_test \
+ vogon_test \
+ shutdown_test
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc43.patch b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
new file mode 100644
index 000000000000..4a61b5ffd04b
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc43.patch
@@ -0,0 +1,23 @@
+--- epos-2.5.37.orig/src/nnet/neural.cc
++++ epos-2.5.37/src/nnet/neural.cc
+@@ -38,7 +38,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <stdlib.h>
+-#include <iostream.h>
++#include <iostream>
+ #include <time.h>
+
+ /*
+--- epos-2.5.37.orig/arch/win/service/install.cpp
++++ epos-2.5.37/arch/win/service/install.cpp
+@@ -23,7 +23,7 @@
+ #include <winsvc.h>
+ #include "service.h"
+ #include <stdio.h> //sprintf & fopen
+-#include <iostream.h>
++#include <iostream>
+ #include "Shlwapi.h"
+
+ SC_HANDLE scm;
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc45.patch b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
new file mode 100644
index 000000000000..70af1db94407
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc45.patch
@@ -0,0 +1,15 @@
+Fixing build with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=318585
+
+--- src/nnet/neural_parse.yy
++++ src/nnet/neural_parse.yy
+@@ -255,7 +255,7 @@
+
+ int yyerror (char *s)
+ {
+- shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf, s));
++ shriek (812, fmt ("BISON:yyerror:bison_nnet parser: bison_row %i (not counting empty rows) '%s' is erroneous. %s\n", row_num, bison_row_buf.c_str(), s));
+ return -1;
+ }
+
diff --git a/app-accessibility/epos/files/epos-2.5.37-gcc47.patch b/app-accessibility/epos/files/epos-2.5.37-gcc47.patch
new file mode 100644
index 000000000000..6e795e3548a9
--- /dev/null
+++ b/app-accessibility/epos/files/epos-2.5.37-gcc47.patch
@@ -0,0 +1,16 @@
+ https://bugs.gentoo.org/440354
+
+ src/nnet/map.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/nnet/map.h
++++ b/src/nnet/map.h
+@@ -25,7 +25,7 @@ T2 & TMap<T1,T2>::operator [] (const T1 &key) {
+ else {
+ TData x;
+ x.first() = key;
+- return insert (x)->second();
++ return this->insert (x)->second();
+ }
+ }
+
diff --git a/app-accessibility/epos/files/eposd b/app-accessibility/epos/files/eposd
new file mode 100644
index 000000000000..b245da92a233
--- /dev/null
+++ b/app-accessibility/epos/files/eposd
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use alsasound esound
+}
+
+start() {
+ ebegin "Starting eposd"
+ start-stop-daemon --start --quiet --background --make-pidfile --pidfile /var/run/eposd.pid \
+ --exec /usr/bin/eposd -- -f
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping eposd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/eposd.pid
+ eend $?
+}
diff --git a/app-accessibility/epos/metadata.xml b/app-accessibility/epos/metadata.xml
new file mode 100644
index 000000000000..e85edf9eb1de
--- /dev/null
+++ b/app-accessibility/epos/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <upstream>
+ <remote-id type="sourceforge">epos</remote-id>
+ </upstream>
+</pkgmetadata>