summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-07-15 09:15:40 +0200
committerHans de Graaff <graaff@gentoo.org>2024-07-15 09:47:45 +0200
commitd2b5d57bf75305508ca99d3bbfccd0d04cb2a647 (patch)
tree2c3e8d56b5b49e65eefa1c58aef4deef679ec1db
parentdev-ruby/mini_magick: add 4.13.2 (diff)
downloadgentoo-d2b5d57bf75305508ca99d3bbfccd0d04cb2a647.tar.gz
gentoo-d2b5d57bf75305508ca99d3bbfccd0d04cb2a647.tar.bz2
gentoo-d2b5d57bf75305508ca99d3bbfccd0d04cb2a647.zip
dev-ruby/mini_magick: drop 4.12.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/mini_magick/Manifest1
-rw-r--r--dev-ruby/mini_magick/mini_magick-4.12.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-ruby/mini_magick/Manifest b/dev-ruby/mini_magick/Manifest
index a435e55209f9..7b359464a7ef 100644
--- a/dev-ruby/mini_magick/Manifest
+++ b/dev-ruby/mini_magick/Manifest
@@ -1,3 +1,2 @@
-DIST mini_magick-4.12.0.tar.gz 1331356 BLAKE2B 84d222424c354e83a041f2c6352f92d11889ed51126f90dd55ccbdbfa31974b79977bf3cf10d30c5f350d17a7dd2d20bf538c2eb78f65c58a29a81f71290acf8 SHA512 8801b4fe9cfed47eeae91cffd5364ca828f8b21d7040217d72d0f5ca9070e02f191b8f87b933c067c0d914332806f14e1b87621dbca06df047c43db8a72cd559
DIST mini_magick-4.13.1.tar.gz 1330619 BLAKE2B ea51265c68b247c8558381e359660b649834c63cdc0de55c9bc47a2ae83ef4f592c14a7f84e12e016860363ba6326ac342481f25a4bc718c059515c30d48fd2d SHA512 2c9a55e69f3770974fa32124ac7f0da63114c17704848d3c957bcfa6b2e00d162694a4e34a25e27f8b214101d6a4bb6a9f1d0dbee597140b94874409ebea4363
DIST mini_magick-4.13.2.tar.gz 1330632 BLAKE2B 831d6676cf2e65f857f149db77086ff9a8a209cf9aa4cfb0dc38a73e82b5d10605cf105d7126f0319203a9cae824e0b94812cf450ad5552316bbd94e21f71365 SHA512 a7a4628fe523816aef37eecfd755b84d11072c6c57134fd3b237312f302d41d2cccc2cefcbf1ef7a291d97d02b830887aa0f628140c51ca28fa9f955c6f96b57
diff --git a/dev-ruby/mini_magick/mini_magick-4.12.0.ebuild b/dev-ruby/mini_magick/mini_magick-4.12.0.ebuild
deleted file mode 100644
index de35c26658a2..000000000000
--- a/dev-ruby/mini_magick/mini_magick-4.12.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Manipulate images with minimal use of memory"
-HOMEPAGE="https://github.com/minimagick/minimagick"
-SRC_URI="https://github.com/minimagick/minimagick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="minimagick-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="test"
-
-# It's only used at runtime in this case because this extension only
-# _calls_ the commands. But when we run tests we're going to need tiff
-# and jpeg support at a minimum.
-RDEPEND+=" media-gfx/imagemagick"
-DEPEND+=" test? ( virtual/imagemagick-tools[jpeg,png,tiff] )"
-
-ruby_add_bdepend "test? ( dev-ruby/mocha dev-ruby/webmock )"
-
-all_ruby_prepare() {
- # remove executable bit from all files
- find "${S}" -type f -exec chmod -x {} +
-
- sed -i -e '/\([Bb]undler\|pry\)/ s:^:#:' spec/spec_helper.rb || die
-
- # Don't force a specific formatter but use overall Gentoo defaults.
- sed -i -e '/config.formatter/d' spec/spec_helper.rb || die
-
- # Avoid broken spec that does not assume . in path name
- sed -i -e '/reformats a layer/,/end/ s:^:#:' spec/lib/mini_magick/image_spec.rb || die
-
- # Avoid spec broken by recent imagemagick updates
- sed -i -e '/cache files generated from .mpc/askip' spec/lib/mini_magick/image_spec.rb || die
- sed -i -e '/does not hang when parsing verbose data/askip' spec/lib/mini_magick/image_spec.rb || die
- sed -i -e '/reads exif/askip "Now returns more complete EXIF data"' spec/lib/mini_magick/image_spec.rb || die
-
- # Avoid graphicsmagick tests because installing both in parallel for
- # tests is hard.
- sed -i -e 's/:graphicsmagick//' spec/spec_helper.rb || die
- sed -i -e '/identifies when gm exists/,/^ end/ s:^:#:' spec/lib/mini_magick/utilities_spec.rb || die
- sed -i -e '/returns GraphicsMagick/,/^ end/ s:^:#:' spec/lib/mini_magick_spec.rb || die
- sed -i -e 's/"GraphicsMagick"//' spec/lib/mini_magick/image_spec.rb || die
-
- # Avoid posix-spawn tests because is not the default, does not work with ruby30 and appears to be unmaintained.
- sed -e '/SHELL_APIS.*posix-spawn/ s:^:#:' \
- -e 's/"posix-spawn"//' \
- -i spec/spec_helper.rb || die
-}