summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-12-23 20:21:53 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-12-23 20:31:51 +0100
commitc78cddc3c29e0b501273b55069fd8b22d7c4f91e (patch)
tree8f7d108a64c4e3e8a19b3286c040c83d13ac27b5
parentdev-libs/metee: add 4.3.0 (diff)
downloadgentoo-c78cddc3c29e0b501273b55069fd8b22d7c4f91e.tar.gz
gentoo-c78cddc3c29e0b501273b55069fd8b22d7c4f91e.tar.bz2
gentoo-c78cddc3c29e0b501273b55069fd8b22d7c4f91e.zip
x11-misc/dunst: add 1.12.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--x11-misc/dunst/Manifest1
-rw-r--r--x11-misc/dunst/dunst-1.12.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/x11-misc/dunst/Manifest b/x11-misc/dunst/Manifest
index 4a6d6e35e109..bafc075a3ce1 100644
--- a/x11-misc/dunst/Manifest
+++ b/x11-misc/dunst/Manifest
@@ -1,2 +1,3 @@
DIST dunst-1.11.0.tar.gz 4645279 BLAKE2B 0daa8d098f032a0e3b16872bc2e33c8411e8eed543fc13533e649935d2d0796ad74b3fb27769f839972b335b7a2f7ae6b5efd9f324a8bb807ac2f82fa8611a5d SHA512 84c9edccddd183fb867233cb5377115d96735f4c1be84007194ac39dd48d913e5bb021d2952057aecdb978564c2471a8974c4ee4eeccfb188e5345527007a5c4
DIST dunst-1.12.0.tar.gz 4653739 BLAKE2B ee537ae10333e41d478f8707d88ff892fad8277038efa7c0180fcbea070ef256060aff8bf2d5c9ac9ebe13e69d3d31066007a8eaf2ca3e1c33f5c922abe22714 SHA512 c969d1bc669cd4b56ebb24ac5ad915aea2776746caf06a941630faff662ed08a05d4652946102428d66e5a89c9144e5d0bfcf7113f8fba3e7c28f0777b490052
+DIST dunst-1.12.1.tar.gz 4654978 BLAKE2B 61dfb8c3e56367cb2afed925f4ee66891ae8edd68837d6391889972aff46683eb5fe8fbf5951e30d6be9074aa648be480847e46cc36c2db6bb4024b42c02064c SHA512 0b4ef72bde6bd4b535f11b58d8bf463df3b9b06d5e2ff40e327eb25f13771eb52c7f7aa91590c6d1228ecb3bc2105510409b6984dd45b5e747c1141f3b79b46c
diff --git a/x11-misc/dunst/dunst-1.12.1.ebuild b/x11-misc/dunst/dunst-1.12.1.ebuild
new file mode 100644
index 000000000000..e8f5e3849fbe
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.12.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Lightweight replacement for common notification daemons"
+HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+completions +dunstify wayland +X +xdg"
+
+DEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X?,glib]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango[X?]
+ dunstify? ( x11-libs/libnotify )
+ wayland? ( dev-libs/wayland )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ xdg? ( x11-misc/xdg-utils )
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+ wayland? ( dev-libs/wayland-protocols )
+"
+
+REQUIRED_USE="|| ( wayland X )"
+
+src_prepare() {
+ default
+
+ # Respect users CFLAGS
+ sed -e 's/-Os//' -i config.mk || die
+
+ # Use correct path for dbus and system unit
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i dunst.systemd.service.in || die
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" -i org.knopwob.dunst.service.in || die
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+src_compile() {
+ local myemakeargs=(
+ DUNSTIFY="$(usex dunstify 1 0)"
+ SYSCONFDIR="${EPREFIX}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ local myemakeargs=(
+ COMPLETIONS="$(usex completions 1 0)"
+ DUNSTIFY="$(usex dunstify 1 0)"
+ PREFIX="${ED}/usr"
+ SYSCONFDIR="${ED}/etc/xdg"
+ SYSTEMD="0"
+ WAYLAND="$(usex wayland 1 0)"
+ X11="$(usex X 1 0)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ systemd_newuserunit dunst.systemd.service.in dunst.service
+}