summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 11:48:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 11:48:34 +0200
commitc1865d7c975ba9f53a15be77f18645c3aa9a74a3 (patch)
tree84d2200ae94264e1fd46b1a67703e6dd84eb4de8
parentdistutils-r1.eclass: Support GPEP517_TESTING mode (diff)
downloadgentoo-c1865d7c975ba9f53a15be77f18645c3aa9a74a3.tar.gz
gentoo-c1865d7c975ba9f53a15be77f18645c3aa9a74a3.tar.bz2
gentoo-c1865d7c975ba9f53a15be77f18645c3aa9a74a3.zip
dev-python/gpep517: Bump to v2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index f99e0b39a4c3..131c95dfdddd 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1 +1,2 @@
DIST gpep517-1.gh.tar.gz 6871 BLAKE2B a298a445cb24dbc708985ebe0be266ed6549525a2b9d250ddb53129502f04a442927ca4c29445f4caf4ada82e106e5498c9586e78dd8a4bd676c7aff747544b6 SHA512 83ccf6124e388aefcdece391d12daf6a337d52b7bb794268effd2abc9bdab6b00d935d01cac774b4a66704578160e44617b16a5b8b9ef821012d419848145e9c
+DIST gpep517-2.gh.tar.gz 6904 BLAKE2B 5d6f8c02805fec0b9c9929a133817be5d06c76ca2dd5ecd6b59d04eca1ca746b2a63a84df29c929ca06a026eef741a2d872abede6f1d0ac3719ff2005cf20043 SHA512 2b1fce7193a5c03175c34251987f42fe82c79a6eef324759fe5728e0f3b66a10f8aa644ece2193c912e9977f21b14a28fe5c9443e3b01ca8cdacf862afe0838c
diff --git a/dev-python/gpep517/gpep517-2.ebuild b/dev-python/gpep517/gpep517-2.ebuild
new file mode 100644
index 000000000000..0fbf09a24da9
--- /dev/null
+++ b/dev-python/gpep517/gpep517-2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/mgorny/gpep517/
+"
+SRC_URI="
+ https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}