summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-04-30 00:49:38 +0100
committerSam James <sam@gentoo.org>2021-05-04 22:17:09 +0000
commitb6346d471e739bc4def7dc86a2e25e15de45e49a (patch)
tree47346716b8bc36dc5bbe21d4a15d41f83d23933f
parentmedia-sound/wav2json: Respect CFLAGS/LDFLAGS/CXX (diff)
downloadgentoo-b6346d471e739bc4def7dc86a2e25e15de45e49a.tar.gz
gentoo-b6346d471e739bc4def7dc86a2e25e15de45e49a.tar.bz2
gentoo-b6346d471e739bc4def7dc86a2e25e15de45e49a.zip
net-analyzer/hunt: Respect CFLAGS
Closes: https://bugs.gentoo.org/724864 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/hunt/files/hunt-1.5-gentoo.patch5
-rw-r--r--net-analyzer/hunt/hunt-1.5_p6_p1.ebuild17
2 files changed, 11 insertions, 11 deletions
diff --git a/net-analyzer/hunt/files/hunt-1.5-gentoo.patch b/net-analyzer/hunt/files/hunt-1.5-gentoo.patch
index e0bcccae0aae..b5b49944f016 100644
--- a/net-analyzer/hunt/files/hunt-1.5-gentoo.patch
+++ b/net-analyzer/hunt/files/hunt-1.5-gentoo.patch
@@ -8,7 +8,10 @@
--- a/tpserv/Makefile
+++ b/tpserv/Makefile
-@@ -3,7 +3,7 @@
+@@ -1,9 +1,8 @@
+-CFLAGS=-Wall -O2 -g
+-
++CFLAGS += -Wall
all: tpserv
tpserv: tpserv.o
diff --git a/net-analyzer/hunt/hunt-1.5_p6_p1.ebuild b/net-analyzer/hunt/hunt-1.5_p6_p1.ebuild
index ec3c6e7a044a..3790bdef6529 100644
--- a/net-analyzer/hunt/hunt-1.5_p6_p1.ebuild
+++ b/net-analyzer/hunt/hunt-1.5_p6_p1.ebuild
@@ -1,31 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit flag-o-matic toolchain-funcs
-DESCRIPTION="tool for checking well known weaknesses in the TCP/IP protocol"
+DESCRIPTION="Tool for checking well known weaknesses in the TCP/IP protocol"
HOMEPAGE="http://lin.fsid.cvut.cz/~kra/index.html"
SRC_URI="
mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig.tar.gz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-$(ver_cut 4).$(ver_cut 6).diff.gz
-"
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-$(ver_cut 4).$(ver_cut 6).diff.gz"
+S="${WORKDIR}/${P/_p*}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
+
PATCHES=(
+ "${WORKDIR}"/${PN}_1.5-6.1.diff
"${FILESDIR}"/${P/_p*}-exit.patch
"${FILESDIR}"/${P/_p*}-gentoo.patch
"${FILESDIR}"/${P/_p*}-log2.patch
"${FILESDIR}"/${P/_p*}-tpserv-log.patch
)
-S=${WORKDIR}/${P/_p*}
-
-src_prepare() {
- eapply "${WORKDIR}"/${PN}_${PV/_p*}-$(ver_cut 4).$(ver_cut 6).diff
- default
-}
src_configure() {
append-cppflags -DSYNC_FAST