summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-19 20:44:31 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-19 21:08:38 +0300
commit97a666e16a29cd9544c8c2bfd5ecc77d8ba9066b (patch)
tree4b63c944b89d0eb2a4a6bc5eb096dd76770d2cd7
parentdev-python/PyPDF2: add 2.3.1 (diff)
downloadgentoo-97a666e16a29cd9544c8c2bfd5ecc77d8ba9066b.tar.gz
gentoo-97a666e16a29cd9544c8c2bfd5ecc77d8ba9066b.tar.bz2
gentoo-97a666e16a29cd9544c8c2bfd5ecc77d8ba9066b.zip
dev-python/uncertainties: add 3.1.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/uncertainties/Manifest1
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.7.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
index e6411d5e9018..aa347a6caa00 100644
--- a/dev-python/uncertainties/Manifest
+++ b/dev-python/uncertainties/Manifest
@@ -1 +1,2 @@
DIST uncertainties-3.1.6.tar.gz 158419 BLAKE2B 09582936a9b982efeee6cf3c99de568ebc820940ca2bfa1e4fd10edbcbd9447e7711158f8b98567a506d6c5a9ecf63b6e21d296c7f8d8dcbbaf4c2fb6a571355 SHA512 8835ed851d00bbe830770e57bc89ce57acf291e6cef2fca59897adb75e1e2de456da3631f73242ade20f567358b1d727b2b7f5df02e2f3e0cd8d861e81a6a211
+DIST uncertainties-3.1.7.tar.gz 158727 BLAKE2B d68b74d291b1f6c4505a47f6fa19653eade43dc1ccaf78e02bd320df92d8bdaeac1b0808a21dceb046a6e2acd076836728b4014d39ca8da17647582320ce50e8 SHA512 24576415265df22459d83bb28e632195e6760204a6e11523821afe25222ea3e035bf7f10c552ec456bb2cdf42a09e296865f9bf0d13ff44beb88c11ebc479ff9
diff --git a/dev-python/uncertainties/uncertainties-3.1.7.ebuild b/dev-python/uncertainties/uncertainties-3.1.7.ebuild
new file mode 100644
index 000000000000..6a0cd2fa7e53
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc --no-autodoc
+
+pkg_postinst() {
+ optfeature "numpy support" dev-python/numpy
+}