summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-07-02 10:45:55 +0100
committerMatthew Smith <matthew@gentoo.org>2022-07-02 10:45:55 +0100
commit9645f0cf2f75834ae139ab8974cedc2395fa5bf1 (patch)
tree43ed9d0f4d860a7d351dc81d97c19ce97d9f7dec
parentdev-vcs/cvsgraph: replace virtual/jpeg dependency (diff)
downloadgentoo-9645f0cf2f75834ae139ab8974cedc2395fa5bf1.tar.gz
gentoo-9645f0cf2f75834ae139ab8974cedc2395fa5bf1.tar.bz2
gentoo-9645f0cf2f75834ae139ab8974cedc2395fa5bf1.zip
app-crypt/mkp224o: add 1.6.1
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--app-crypt/mkp224o/Manifest1
-rw-r--r--app-crypt/mkp224o/mkp224o-1.6.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/mkp224o/Manifest b/app-crypt/mkp224o/Manifest
index 7048da480d16..4bd4fdc62350 100644
--- a/app-crypt/mkp224o/Manifest
+++ b/app-crypt/mkp224o/Manifest
@@ -1 +1,2 @@
DIST mkp224o-1.5.0-src.tar.gz 1378324 BLAKE2B 19d38fbf23328607fa428ec9329cdc909b210b4235d85e14ff372347c9b408ecf22d41dac7122bdae06725d7bca0c3d53c81cc27272c47517e714e9b8e0625dd SHA512 aa5adc91e695dbfd8ece5fdfe3ca370056d4390a5186326b35ee37402040fa24675ede5389c48b79a1e57b624b86024ff72957741fef175602f7721f20c5cc14
+DIST mkp224o-1.6.1-src.tar.gz 1387615 BLAKE2B 271424dcee44b5b1e1a35346a0cc1c37ee5d430231fe93e0b936ac994c892f0406ea361be763732db8a8397684ecad70e26c34f5553a415e7ed0592417672310 SHA512 d0c21ee5fb5f7b2950e1c39af5dc62b1e26aef0917b53169e9c3f9a99a7febe70bb2f96ada612c71bdbdbf8cad9c1f407d175af49fca40eedd68bbe8112970a5
diff --git a/app-crypt/mkp224o/mkp224o-1.6.1.ebuild b/app-crypt/mkp224o/mkp224o-1.6.1.ebuild
new file mode 100644
index 000000000000..6a5af08b0f9c
--- /dev/null
+++ b/app-crypt/mkp224o/mkp224o-1.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Vanity address generator for v3 Tor hidden service addresses"
+HOMEPAGE="https://github.com/cathugger/mkp224o"
+SRC_URI="https://github.com/cathugger/${PN}/releases/download/v${PV}/${PN}-${PV}-src.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 pcre2"
+
+DEPEND="
+ dev-libs/libsodium:=
+ pcre2? ( dev-libs/libpcre2:= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( OPTIMISATION.txt README.md )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-regex=$(usex pcre2)
+ --enable-statistics
+ )
+ use cpu_flags_x86_sse2 && myeconfargs+=( --enable-donna-sse2 )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+}