summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-10-24 14:21:48 +0200
committerFabian Groffen <grobian@gentoo.org>2017-10-24 14:42:57 +0200
commit5f9d88906c6b49f89b423f720b0296cc01b98bb1 (patch)
tree7917df6c493d204ad26a7d2e5bf95c64eef29097
parentmedia-gfx/shotwell: Version bump to shotwell-0.27.1 (diff)
downloadgentoo-5f9d88906c6b49f89b423f720b0296cc01b98bb1.tar.gz
gentoo-5f9d88906c6b49f89b423f720b0296cc01b98bb1.tar.bz2
gentoo-5f9d88906c6b49f89b423f720b0296cc01b98bb1.zip
sys-apps/gawk: fix Solaris standards conflict resolution
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--sys-apps/gawk/gawk-4.2.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/gawk/gawk-4.2.0.ebuild b/sys-apps/gawk/gawk-4.2.0.ebuild
index da57da475731..231bcb851dcf 100644
--- a/sys-apps/gawk/gawk-4.2.0.ebuild
+++ b/sys-apps/gawk/gawk-4.2.0.ebuild
@@ -38,7 +38,8 @@ src_prepare() {
# fix standards conflict on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
sed -i \
- -e '/\<_XOPEN_SOURCE\>/s/$/600/' \
+ -e '/\<_XOPEN_SOURCE\>/s/1$/600/' \
+ -e '/\<_XOPEN_SOURCE_EXTENDED\>/s/1//' \
extension/inplace.c || die
fi
}