summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-14 21:57:39 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-15 09:10:42 +0200
commit5ea261a1a04edeae16aefe94b2585626f9345144 (patch)
treec1a20485d216684e109a34c26d88f72b139731f6
parentdev-lang/eisl: bump to 5.00 (diff)
downloadgentoo-5ea261a1a04edeae16aefe94b2585626f9345144.tar.gz
gentoo-5ea261a1a04edeae16aefe94b2585626f9345144.tar.bz2
gentoo-5ea261a1a04edeae16aefe94b2585626f9345144.zip
app-containers/earthly: drop old 0.8.12
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.12.ebuild71
2 files changed, 0 insertions, 73 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index b0276f55d494..f83095a2ef1d 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,5 +1,3 @@
-DIST earthly-0.8.12-deps.tar.xz 163755972 BLAKE2B 6d5e7e2d157b54818bebca7cc0b57be23be4581660bae8002bb90983cc9478d9d05ebea3dd102123ced6c1f1a8b94f93ca0868c040defa1fb5f0137f901b1c50 SHA512 bcfc4eecfceefcf5677f145475406fe4fef9d3a70c177ea657f2f0eec7227c752fcc01b129c001fbb8d9fa6ba934a6425b0fb0957b6812d2f751e7d3b99dd0a2
-DIST earthly-0.8.12.tar.gz 8090651 BLAKE2B ce916a50b23bc5567b4174ad88a5a52b9c728b4ee215239f46680fe5574f0cabe353d5a336e395f7eec42c86a726bb0d0da4b5204dcc9654c76a8a8cd3366fb4 SHA512 7cc62cc3af6aef039f8059e04564a181dd9b497cb51f15b6a49f2aad4a975147aa30d9109eb1c33cfc74a6f354eae77904d5c0e15e63172cb7ee20874b9bc05e
DIST earthly-0.8.13-deps.tar.xz 163750220 BLAKE2B 995ed748f99b7d4c4ca90cdd1964c295270963e55462bfa3bdd830209a90303d67c91fed66e7d52984993ef58b1d060e140694fdc8931ca2181dd88701d8f6dd SHA512 ab3ee4fef9a87dab9009ffd4e31d00a256c8ad88096c8573a5a2fb782079392415752024821240da60549d260c9dcfe3d6f1457fb3fbc8cc8a1f2602bb875aee
DIST earthly-0.8.13.tar.gz 8082676 BLAKE2B cf6d5c6d397951a60302e5492ad219d3d673cce9bf2e06696a3cd8719dcf1d755644413171c7db1b27c60d6cbe0d85facf2d6a5d150c26dc5530c07d1255b742 SHA512 f3abd814c0c57f485a37c83e322d9a8478236ae4220baf455330a6a28d98a8cb7806fb4cee9525c9b27c51bc0ed8780872f51ece7194059658defd54cce1a6b5
DIST earthly-0.8.14-deps.tar.xz 163777848 BLAKE2B 0615db6d874a0d490666df6517581763315c44a67662d1c8c630d59983849c3a1c10bdee4d626f9ded02a58f7eb037e24cca6b22dfc7eadf79d4e735a33306c5 SHA512 ac062ae77e98ec36f9bba1a73430080d2f2c7bed3ad8c48af8bb1da4a6f006a4285fca8f4d85363652ec3db9df78e76befdfc838971684d704512d795d672414
diff --git a/app-containers/earthly/earthly-0.8.12.ebuild b/app-containers/earthly/earthly-0.8.12.ebuild
deleted file mode 100644
index 2b39a6ae5bc6..000000000000
--- a/app-containers/earthly/earthly-0.8.12.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
-if [[ "${PV}" == "0.8.12" ]] ; then
- COMMIT_SHA="7dbb0eab6af95b6f43483ff4065445470252f522"
-else
- die 'Could not detect "COMMIT_SHA", please update the ebuild.'
-fi
-
-inherit go-module
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_compile() {
- local -r go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local -r go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${COMMIT_SHA}
- -X main.Version=v${PV}
- "
- local -a -r go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o ./bin/
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}