summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-10 21:29:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-10 21:30:02 +0300
commit537cc579c03d3efa35a63540d157842c2a966b8a (patch)
tree65d43f89674239e99ee4aeff937e197e66aeeef9
parentapp-admin/ps_mem: update EAPI 7 -> 8 (diff)
downloadgentoo-537cc579c03d3efa35a63540d157842c2a966b8a.tar.gz
gentoo-537cc579c03d3efa35a63540d157842c2a966b8a.tar.bz2
gentoo-537cc579c03d3efa35a63540d157842c2a966b8a.zip
dev-util/ostree: add 2023.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-util/ostree/Manifest1
-rw-r--r--dev-util/ostree/ostree-2023.2.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
index fb9c66791c36..3538e42ec57f 100644
--- a/dev-util/ostree/Manifest
+++ b/dev-util/ostree/Manifest
@@ -1,3 +1,4 @@
DIST ostree-2022.6.tar.xz 2124464 BLAKE2B c6ea1f11d08261e8532345ffc18bec9e77d04e63aab0c8e2eb03a4b3d3c2c594bcc9e6c5341e4caefe81fbd06a055cd39b0f2f2b43d3e876837a9bac43c704f5 SHA512 03f6b6947a372e36d3a1ae3bbe47543c562113039ce10db9c6f26a7b4015afb41950bd00bd1931937a5fb3043689ca1046eb87afd890571cfedbfa1ef36219a7
DIST ostree-2022.7.tar.xz 2076728 BLAKE2B 7308be450e4aa9bebe3e8b86031bf75b7d0cd07a2e36d6d11d01aa8e8d19ed02e8560931a83f18856c7d4fc7ae6045d22b6aa4d7f577f3df9e704ae9d7562d3e SHA512 725eff027b2c4c1aec0c222a5fa6059f3a777f4d0c831b82a4021befba0078692aa5ced2c4c609530c70462b4148a3cc33152e3d9dc4a5d6f8cf98f61ef09c2a
DIST ostree-2023.1.tar.xz 2079904 BLAKE2B 993570624cb43684d81fff9f3789a9cee3b998f945a78bc6eb99330eed45739d1e6fb66589cefba10eea608c5cd389cc121a890c27efa773a405a5d8b1f117d9 SHA512 a6a6e47d6cb9ec6826d48a50a2abac69e4a040f2b5830d39e8a006c738a163fb15fde8630bf271d92cec9470601281669cd4bf942e4b7c4d42441bd5d1730572
+DIST ostree-2023.2.tar.xz 2081320 BLAKE2B f773bf979b4bc97b9b8f96dc4385745bc386c29952a36c07cdd33a7db7802876ce154b5ac1f3669605ab3949a539aa8e2b3a3d94608557eb65249b5188f9d012 SHA512 549a2bdf8cef93d421aaf990e2d1c534063f0314b5933db7ce123bdd138229e24cc171d541296e45a7546a91d35149c1c8f29ea90949876200c574e7ec297b98
diff --git a/dev-util/ostree/ostree-2023.2.ebuild b/dev-util/ostree/ostree-2023.2.ebuild
new file mode 100644
index 000000000000..32ce2d1f9766
--- /dev/null
+++ b/dev-util/ostree/ostree-2023.2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd tmpfiles
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostreedev.github.io/ostree/"
+SRC_URI="
+ https://github.com/ostreedev/ostree/releases/download/v${PV}/lib${P}.tar.xz
+ -> ${P}.tar.xz
+"
+S="${WORKDIR}/lib${P}"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="archive +curl doc dracut gnutls +gpg grub +http2 httpd introspection libmount selinux sodium ssl +soup systemd zeroconf"
+RESTRICT="test"
+REQUIRED_USE="
+ dracut? ( systemd )
+ http2? ( curl )
+ httpd? ( || ( curl soup ) )
+"
+
+RDEPEND="
+ app-arch/xz-utils
+ dev-libs/libassuan
+ dev-libs/glib:2
+ sys-fs/fuse:3
+ sys-libs/zlib
+ archive? ( app-arch/libarchive:= )
+ curl? ( net-misc/curl )
+ dracut? ( sys-kernel/dracut )
+ gpg? (
+ app-crypt/gpgme:=
+ dev-libs/libgpg-error
+ )
+ grub? ( sys-boot/grub:2= )
+ introspection? ( dev-libs/gobject-introspection )
+ libmount? ( sys-apps/util-linux )
+ selinux? ( sys-libs/libselinux )
+ sodium? ( >=dev-libs/libsodium-1.0.14:= )
+ soup? ( net-libs/libsoup:2.4 )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ )
+ systemd? ( sys-apps/systemd:0= )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ doc? ( dev-util/gtk-doc )
+"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/ostree-2022.6-musl-allperms.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Needs Bison (bug #884289)
+ unset YACC
+
+ local econfargs=(
+ --enable-man
+ --enable-shared
+ --with-grub2-mkconfig-path=grub-mkconfig
+ --with-modern-grub
+ $(use_with archive libarchive)
+ $(use_with curl)
+ $(use_with dracut dracut yesbutnoconf) #816867
+ $(use_enable doc gtk-doc)
+ $(usex introspection --enable-introspection={,} yes no)
+ $(use_with gpg gpgme)
+ $(use_enable http2)
+ $(use_enable httpd trivial-httpd-cmdline)
+ $(use_with selinux )
+ $(use_with soup)
+ $(use_with libmount)
+ $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; })
+ $(use_with sodium ed25519-libsodium)
+ $(use_with systemd libsystemd)
+ $(use_with zeroconf avahi)
+ )
+
+ if use systemd; then
+ econfargs+=( --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" )
+ fi
+
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ tmpfiles_process ostree-tmpfiles.conf
+}