summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-12-18 20:11:02 +0000
committerSteve Dibb <beandog@gentoo.org>2009-12-18 20:11:02 +0000
commit3cd9a10d883282e4dcb440b3cf14f8990fc2bb8a (patch)
tree9405074a9b75df9f4c78d44616c731e180a83f59
parentChange version to assume there is only one alpha after a digit version (diff)
downloadznurt-org-backend-3cd9a10d883282e4dcb440b3cf14f8990fc2bb8a.tar.gz
znurt-org-backend-3cd9a10d883282e4dcb440b3cf14f8990fc2bb8a.tar.bz2
znurt-org-backend-3cd9a10d883282e4dcb440b3cf14f8990fc2bb8a.zip
Check for use flag reqs; fex: foo/bar[use]
git-svn-id: file:///var/svn/portage@5 3218660a-b0cf-4799-a991-8ddcc5b9e0f3
-rw-r--r--class.portage.ebuild.php2
1 files changed, 1 insertions, 1 deletions
diff --git a/class.portage.ebuild.php b/class.portage.ebuild.php
index 2be24b7..1498888 100644
--- a/class.portage.ebuild.php
+++ b/class.portage.ebuild.php
@@ -431,7 +431,7 @@
// That a version that has both digits and letters (see ([A-Za-z])? ) that there is
// ONLY one letter (fex: openssl-0.9a). This lets us catch the pn properly of
// atoms like font-adobe-100dpi, where it would normally think 100dpi = version.
- $pattern = '/\-\d+((\.?\d+)+)?([A-Za-z])?((_(alpha|beta|pre|rc|p)\d*)+)?(\-r\d+)?(\:.+)?$/';
+ $pattern = '/\-\d+((\.?\d+)+)?([A-Za-z])?((_(alpha|beta|pre|rc|p)\d*)+)?(\-r\d+)?(\:.+)?([.+])?$/';
$arr = preg_split($pattern, $str);
$this->pn = $arr[0];